0 Favourites

Bugs to fix FAST

This forum is currently in read-only mode.
  • Also, just on the subject on 3DBoxes. I noticed that although you can add Private Variables to them, there is no way to actually utilize those private variables in the Event Manager. At least that I am aware of. Is this functionality a possibility in the future? It would open up quite a few doors for me <img src="{SMILIES_PATH}/icon_smile.gif" alt=":)" title="Smile" />.

  • Ah, silly omission from 3D box. Will add for 0.84. I'll look in to the 3D box problem too, sounds like a device reset problem. Does saving the .cap, closing construct and opening it again display a 3D box properly?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Does saving the .cap, closing construct and opening it again display a 3D box properly?

    Not for me. Screen remains black.

  • Does saving the .cap, closing construct and opening it again display a 3D box properly?

    Not for me either. Re-opening the file causes the black screen to occur again.

    Its like the initial render for the 3DBox is bugged. If I change my resolution\refresh rate\colour depth (as mentioned in my previous post) to something then change it back (to 'fix', well... work around the issue) then any 3DBoxes placed thereafter appear 100% fine (that is, until I save and re-open the file, then its black screen again).

  • Note if you want a 3D box with private variables before 0.84 you can get it off the CVS, you'll need to download both 3DBox.csx and the one under Runtime.

  • Note if you want a 3D box with private variables before 0.84 you can get it off the CVS, you'll need to download both 3DBox.csx and the one under Runtime.

    Awesome, thanks for the speedy update <img src="{SMILIES_PATH}/icon_biggrin.gif" alt=":D" title="Very Happy">.

  • Note if you want a 3D box with private variables before 0.84 you can get it off the CVS, you'll need to download both 3DBox.csx and the one under Runtime.

    Hmm, I seem to be getting an error with the new 3DBox object. I will test further, but it seems that whenever I am altering a 3dbox private variable through an event it causes the application to crash.

    Is anyone else able to replicate this?

    EDIT: I tried dumbing it down, just to be sure. Even something as simple as "Set 'X' to 1" is causing a crash.

  • Arg, probably did it too quickly. That's the problem with getting stuff off the CVS, it's quick but it's not fully tested, basically a nightly build. I'll fix it.

  • It's fixed, you only need the runtime 3DBox.csx off the CVS.

  • One of the object icons in the Layers panel has an incorrect icon. It's a 3d Box object. I'm sure you're not totally sick of hearing about that object yet <img src="{SMILIES_PATH}/icon_wink.gif" alt=":wink:" title="Wink" />

    Anyway, sometimes the icon displayed is my player sprite, sometimes it's the Mouse&Keyboard icon. It switches around to different icons, which is strange enough. When I open the picture editor to edit the icon, I get a couple of different errors. Sometimes I get:

    An invalid texture handle was used.  
    
    Good luck![/code:2q1myh74]
    
    And other times I get:
    
    [code:2q1myh74]Runtime Error!  
    
    Program: C:\blahblah\Construct.exe
    
    R6205
    [ul]
    	[li]pure virtual function call[/code:2q1myh74][/li]
    [/ul]
    I'm also getting incorrect icons for other objects in the event conditions and actions selectors, and in the event sheet editor, which makes it a little confusing.
  • Can you send me a .cap with the wrong icons? ashleyscirra.com, cheers!

  • Can you send me a .cap with the wrong icons? ashleyscirra.com, cheers!

    A .cap file was sent.
    
    Good luck![/code:3j32doto]
  • I've had a look, and I can see why it crashes - one of the object's icons didn't save for some reason, so it fails to load it and fails editing it. I've no idea why it never saved properly - can you remember what you did before it happened?

  • Unfortunately, no. Sorry <img src="{SMILIES_PATH}/icon_sad.gif" alt=":(" title="Sad" />

    I first noticed the icon was incorrect a few days ago, before v0.84 came out. I figured it was just a tiny little bug, and I could just edit the icon any time. When I finally got around to editing it this morning, I discovered that the problem was bigger than I first thought.

    It's not a terribly big .cap though, I can try recreating it from scratch and see if it happens again. I'll let you know what I find, if anything.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)