0 Favourites

[Photon] SecureWebSocket on Self-hosted Amazon EC2

  • Hi,

    I'm having trouble when I try to connect my self-hosted server (Amazon EC2), using Secure Websocket connection, I followed this tutorial to allow wss: ... -ssl-setup.

    I'm guessing that the problem is related with my certificate but I'm not entirely sure. I tried trusted Certificate Authority one (free SLL Certificate from ).

    Here is the error (i'm using Public IP address):

    Photon Config in Construct 2:

    Here is app's websocket listener in PhotonServer.config:

    <WebSocketListener
    	IPAddress="0.0.0.0"
    	Port="9090"
    	DisableNagle="true"
    	InactivityTimeout="10000"
    	OverrideApplication="Master"
    	Secure = "true"
    	StoreName = "MY"
    	CertificateName = "mydomain.com"
    	UseMachineStore = "true">      
    </WebSocketListener>
    
    <WebSocketListener
    	IPAddress="0.0.0.0"
    	Port="9091"
    	DisableNagle="true"
    	InactivityTimeout="10000"
    	OverrideApplication="Game"
    	Secure = "true"
    	StoreName = "MY"
    	CertificateName = "mydomain.com"
    	UseMachineStore = "true">      
    </WebSocketListener>
    [/code:3lpnwlyr]
    
    Here is my Certificate Authority on Windows Server 2012 R2:
    [img="http://i.imgur.com/jcXnx4y.png"]
    
    "Local computer" certificate store
    [img="http://i.imgur.com/KngJf68.png"]
    
    Thank you
  • Hey

    Did you ever fix this? I'm running into a similar issue.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Curious if Amazon is shipping their windows servers with crypto protocols disabled...

    Download IIScrypto from the web and use it to check if your cert's cypher or protocols are disabled? If so, use that tool to enable and try again?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)