0 Favourites

Weird Layout Behaviours

  • So I'm making a game within one layout. Everything works ok.

    Then I duplicate the first layout, because the next stage will have different environment latter.

    The new layout still using the same event sheet.

    But strangely, eventhough the timescale is 1, the control and the animation stop.

    One of the weird things I observed.

    I have a ship that should shoot lasers constantly. But in this case the ship seems only shoot 1x and it stays at one spot.

    But if I check the debugger, lasers are still created and destroyed constantly.

    My lasers only get destroyed when outside the layout.

    So if the lasers ain't moving outside the layout, how can they get destroyed?

    Are there any particular things I should pay attention when using multiple layout with one event sheet?

  • My first guess would be logic error but its too hard to say without seeing your project. Perhaps you can strip it down to the basics and post it.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Ah, I have found the error. So basically I'm in a loop of restarting the layout forever.

    That's why the animation seems to stop, but the lasers keeps created and destroyed constantly.

    All I have to do is to add trigger only once while true

    Thanks for the input.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
0 Favourites
[BEHAVIOR] Chipmunk Physics
673 82,469
nelostic's avatar
nelostic
Unread hot topic
0 Favourites
[Behavior] LiteTween
672 169,823
manujorgo's avatar
manujorgo
Unread hot topic
564 105,179
rexrainbow's avatar
rexrainbow