0 Favourites

Trying to draw a line starting from the point

  • I want to draw a line, which will start from one point (ImagePoint) to the next point. I did it with setting line width with each tick, but it draws from the point in two directions and I want it only to go up. So basically I want to draw a line which will go just in one direction (upwards). How to do it?

  • Umm coming from a noob who likes math. You could use a line algorithim like ( Bresenham algorithm ) and try and implement it in construct. I will try to do so if i get it working i will post it.

  • Check out in c2folder\examples (in your install of C2 on your HDD) there is one example called "Physics - distance joint.capx".

    In this capx, the line is a sprite (just a color filled) and both sides of the sprite are "tied" to specific points.

    Check it out, this should help you setup things the way you want.

  • I want to draw a line, which will start from one point (ImagePoint) to the next point. I did it with setting line width with each tick, but it draws from the point in two directions and I want it only to go up. So basically I want to draw a line which will go just in one direction (upwards). How to do it?

    Did you try to set the hotspot to the side of the image?

    Like for width set it to 0x, or 4 on the numpad.

    The if using height set it to y max, or 2 on the numpad.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Thank you! Got it covered :) Just like newt proposed I set a hot spot to one side of the image and it's working :)

    Kyatric Unfortunetly I don't have Physics - distance joint.capx example file. Probably because I have a free version?

  • samur

    You should have ALL the same examples as everyone else - even the 'Early Adopters'. The installation file is the same for everyone - just some functionality is different when you pay (more layers, events etc allowed).

    What version have you got? Might want to try re-downloading the current R63 version.

  • OK - after reinstal I have this example. I'll study it, thanks! :)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)