0 Favourites

SOLVED Particles Not Keeping Pace With Fast Object (Car)

  • Hello and thanks for looking. I have a car object that, on button press, creates a particle object on the car imagepoint. Depending on how fast the car is moving, the particle is instantiating well behind it. If stopped, the particle is created exactly where it should be.

    My question is; is this a problem with my pc being too slow or would this happen regardless? I could code in a fix but if it's my pc, then it's not going to look right on the next pc.

    Solved below by Silverforce

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Is the particle a spray or one shot?

    If its a spray, it should always be positioned to the car at that imagepoint.

    If its a one-shot and there's a delay as you say, have a check for your car velocity, if its slow, then use an imagepoint where it looks right. If the car is moving fast, use another imagepoint towards the front of the car, so the particles look correct.

  • The particles are in spray and I could position the imagepoint closer but Im worried that if the delay is caused by a slow pc that when played on a faster pc the particle will instantiate correctly (at this point closer, which would be wrong.)

  • It's due to your spray rate, each interval has a timer, and within that timespan if you car is moving really fast, it would be far in front. It's normal actually.

    If you want accurate smoke trails, you have to adjust the rate to be dynamic, so a faster car will output more trails than a slower one.

    It's nothing to do with PC speed.

  • you're right! If I crank up the particle rate to 60, it instantiates where it should. I had it at 5 per second. It wasn't obvious to me until you posted it...it makes sense. Thanks man!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)