0 Favourites

[Solved] Help with showing ads using AdMob plugin

  • Hello,

    I am having a hard time showing ads in my game. I can't seem to get the ads to display. I will show all the steps that I have done so that anyone can point out if I am missing something.

    I have added AdmobAds to my Construct 2 project.

    I then created an Admob account and created a bottom banner ad.

    I added the Banner IDs to the AdmobAds properties in Construct 2 from my Admob account. ca-app-pub-8251...etc.

    In Construct 2 I then have the following code:

    System > On start of layout > AdmobAds > Preload banner ad

    AdmobAds > On banner ad received > AdmobAds > Show banner ad at position Bottom center size Smart banner (auto-size, recommended)

    On the AdmobAds properties I have Overlap set to Yes and Test Mode set to False.

    I then Export the Construct 2 project to Cordova.

    I have Intel XDK installed. I then import my Construct 2 project.

    I select Yes to Use Cordova plugins.

    Under Projects Properties, the Plugins, I select the Third Party Plugins. From there I select Get plugin from the web.

    I then use the following:

    Name: AdMob Plugin

    Plugin ID: com.cranberrygame.phonegap.plugin.ad.admob

    Check the 'Plugin is located in the Apache Cordova Plugins Registry' box

    I import the settings.

    I then set my Build settings for Android Crosswalk. In this case Landscape and Fullscreen is used.

    I then Build and download my app to my phone. The ads don't show though in the app.

    I am not sure if I am missing something, or if there is something else I need to do? Any help would be greatly appreciated.

  • Also does your game have to be added to the google play store before being able to have the ads show up? I haven't added it yet and on Admob I have it manually created.

  • DId a test ads show up during test mode?

    I just tested with my game. Ads does show up even if you have't export your game to the playstore.

    Your steps seems to be fine.

    Though, I recommend you to update your intelXDK to the latest version, they have added Admob plugin in the third party plugin section. You just need to tick it on and you don't have to get plugin from web. The end results might be the same, but who knows...

  • The test ads don't show up either. Do they only show up on the device/phone, or would they show up on your computer when testing? Maybe I need to create a new ad banner, or test it on another device. Yeah yesterday evening I played around with it more and found that option to just check-on the Admob plugin.

  • The ads (and test ads) only show up in exported apk afaik.

    Ads won't work on pc.

    Could there be a hidden space at the end of your BannerID in C2?

    Maybe you can test with a different condition for showing ads, like on pressed R instead of on banner received. Try this in test mode first though.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • You know what, thanks ikke2901! That was it, a space at the end. lol. Three days trying to figure this out over a simple space. Thanks again, I appreciate it a lot!

  • I had the same problem haha.

    You are welcome SilentScope!

  • DId a test ads show up during test mode?

    I just tested with my game. Ads does show up even if you have't export your game to the playstore.

    You mean in test mode or not ?

    Can ads be preloaded if admob ad unit is not linked to your game in the playstore ?

  • I've been wondering the same....can it?

    Also ... it doesn't really work on pc, right?

  • I've been wondering the same....can it?

    Also ... it doesn't really work on pc, right?

  • Guys.. tell me something... I have created 2 ad units for the same app/game at AdMobs. One for static banner and another for interstitial banner. The thing here is that my ads and test ads won't show up. Not even when exporting.. and there are no side spaces for the ids.. as reported above

    But one thing that I noticed is that the banner ids have a "/" in the middle. Is it ok? For instance: "ca-app-pub-2502326780141231/8249038440"

    Thanks!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)