[Solved] Auto-Mirror/Flip = Gray Screen on Run?

  • Running r65 on a 64-bit machine here. Upon previewing a game in Chrome (file mode, HTTP gives me a localhost error) including sprites marked to auto-flip or auto-mirror, all I get is a gray screen and the app fails to load. I searched through the forums quickly and didn't see this problem in r65.

    Has this happened to anyone else? If so, what did you do to fix/cope with the problem? I'd love to use the auto-mirror to handle sprite directions, obviously. I tested this in multiple browsers, same result.

    (Possibly needless system specs: Win7 64-bit, 4gb RAM, 2.1ghz CPU, ATI & AMD)

  • Auto-flip and auto-mirror only work in HTTP mode because browsers block the necessary features in file mode.

    Sorry - I think your best bet is to try and get HTTP working. Are you running any other servers on your computer?

  • Ahhh, that makes sense. Kyatric speculated that EasyPHP might interfere with the localhost and stated that he ran XAMPP (I believe), no problems. I now have XAMPP and discarded EasyPHP, but the problem persists at all times.

  • You might wanna try r65. Ash resolved some troubles with the previewing, it might be worth taking a shoot at an HTTP preview with it.

  • I'll keep tinkering with it, yes.

  • Did a bit more digging around here and solved the problem--my "hosts" file was configured in a way that didn't allow C2 to use the localhost address. Just in case someone else is having a similar problem, here are the steps I took to fix the issue:

    First, I located the folder that contained my 'hosts' file (c:/windows/system32/drivers/etc/) and opened the actual file using Notepad++ (but Notepad will do, if that's what you've got). In my case, there were two entries near the top that were of particular interest to me:

    #127.0.0.1       localhost

    #::1             localhost

    Notice the '#'? That means it's a comment (i.e doesn't do anything). Delete the #'s. I had a couple entries following this one that were NOT commented out, but used the same address (127.0.0.1). I'm fairly sure I'll need them later, so I simply put the pound symbol (#) next to those to comment them out, as well as save them if I need them later. Finally, I saved the 'hosts' file.

    HTTP preview now works, as does the mirroring/flipping <img src="smileys/smiley36.gif" border="0" align="middle" />

  • Just encountered this problem myself, because I'm mostly using File preview mode to prevent a problem with the server not shutting down when using HTTP preview mode.

    Guess I have to hope to see the HTTP problem fixed in a future C2 release, so I can completely ditch File mode.

    A workaround for me is using Firefox, which seems to work with File preview and auto mirror/flip. So maybe it's just a browser setting and can be done in Chrome/IE9 too? Or is this some oddity that's special to Firefox? Since Ashley said browsers normally block the necessary features...

  • I'm having the same issue, I've added a new layout and when and on the preview mode all I get is a gray screen.

    Anyone knows how to fix this?

  • I'm guessing changing the hosts file didn't work. Did it?

  • Did a bit more digging around here and solved the problem--my "hosts" file was configured in a way that didn't allow C2 to use the localhost address. Just in case someone else is having a similar problem, here are the steps I took to fix the issue:

    First, I located the folder that contained my 'hosts' file (c:/windows/system32/drivers/etc/) and opened the actual file using Notepad++ (but Notepad will do, if that's what you've got). In my case, there were two entries near the top that were of particular interest to me:

    #127.0.0.1       localhost

    #::1             localhost

    Notice the '#'? That means it's a comment (i.e doesn't do anything). Delete the #'s. I had a couple entries following this one that were NOT commented out, but used the same address (127.0.0.1). I'm fairly sure I'll need them later, so I simply put the pound symbol (#) next to those to comment them out, as well as save them if I need them later. Finally, I saved the 'hosts' file.

    HTTP preview now works, as does the mirroring/flipping <img src="smileys/smiley36.gif" border="0" align="middle" />

    thanks man! I was having a bad time trying to figure out why the preview wasn't working anymore. It bring me another problems but I'll look at it later.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'm currently having the same problem with getting a gray screen when I try to run my project. Did you ever figure out how to solve this?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)