0 Favourites

Set solid disable for Platform behavior

  • Hello community.

    I newbe with Construct 2. I just started my platform game and faced with the problem: in my game I have temporary fade-out bricks, when the player is stands on brick is disappearing by fade-out method. In that moment I set Solid is disable, but player still stay on the brick. Looks like solid is still enebled. But if I jump on it, player is falling through without collisions. Can you give me advice? Thank you.

  • I had this problem in a game I made a while back. This was my solution.

    Player is standing on platform * Set platform jump strength to 100

    Block opacity < 100             * Simulate Jump

                                                 * Wait 0.1 Seconds

                                                 *Set platform jump strength back to original

    This meant he gave a little jump when the block vanished, but it worked pretty well. I'm just setting his jump strength to something low, making him jump, then setting the jump strength back.

    Hope this is of some help

  • I'm pretty sure all you have to do is get the player into the air. You could just use something like Set Y vector -1 to launch the player an imperceptible distance into the air.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Thank you guys for your help. Both advices works fine! Issue with fade-outing platforms is solved for me.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
0 Favourites
[BEHAVIOR] Chipmunk Physics
673 82,517
nelostic's avatar
Unread hot topic
0 Favourites
[Behavior] LiteTween
672 169,926
manujorgo's avatar
Unread hot topic
564 105,243
rexrainbow's avatar