0 Favourites

Problem with 'restart layout' and 'go to layout'

  • On the start of the gameplay layout (the action layout) i have several groups deactivated, along with bullet and rotate behavior disabled. There is a 3,2,1 countdown and then everything gets activated and enabled.

    If you touch PLAY from the main menu everything works fine.

    But...if you touch replay from the leaderboards layout, which takes you back to the gameplay layout, the bullet behavior does not enable, so the disks move at 0 angle.

    I've tried moving things around, waiting 0.25 secs, going to layout by name, many things. It just doesn't work if the layout is replayed.

    If anyone has an idea on how to fix this, it'd be greatly appreciated.

    CAPX

  • Have you tried to just make so before the game starts, everything is ona timefreeze 0 and the player has to press a button to start the game?

  • You need to reset things on Start of layout. Groups hold their state by design. Reset your bullets also.

  • Triforce Tried the time scale, but there are some things i can't have included in that. Also, i'd rather have a countdown than a generic "push button to play". May have to revisit the time scale thing.

    blackhornet What do you mean by 'reset'? It works like it should except for the bullet behavior on the starting disks. And they are being enabled right after the action that activates the groups.

  • Triforce Tried the time scale, but there are some things i can't have included in that. Also, i'd rather have a countdown than a generic "push button to play". May have to revisit the time scale thing.

    blackhornet What do you mean by 'reset'? It works like it should except for the bullet behavior on the starting disks. And they are being enabled right after the action that activates the groups.

    There is a event that is

    "ON start of layout -> Reset variables"

  • You should always set your groups activation on startup.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Triforce

    blackhornet

    Thank you for the help. I think i got it now. I added the timescale 0 action i was using for the gameover event(s) and had to move some actions up and down. Funny, i think its the same as i had it before.

    At least its working now.

    And if i can ever figure out this setting player name to array scores... I'll be golden

    Thank you both again.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)