PNG convertion problem

  • Hello guys,

    after exporting my game I noticed on a few of my sprites an annoying black line, like it's showing the edge of the png file.

    Attached picture has an example.

    It's not on all of them, but when you move around it becomes noticeable on multiple sprites. Anybody got an idea what this might cause?

  • Picture turned out a bit small, but if you look good, you can see a tiny line at the edge of the sprite.

  • Picture turned out a bit small, but if you look good, you can see a tiny line at the edge of the sprite.

    i think this is a bug

  • I'm guessing the object is a tiltedbackground. Add a line of empty pixels at the top of the image so you don't get bleed over from the bottom - where c2 tries to blend it due to pixel rounding (or some such visual artefact of the engine). Not a bug but a well documented effect...

  • Thanks guys,,,,the object is just a sprite object white plenty of empty pixels around the drawing part. So am not sure it's the same problem described by Colludium. But it can be a blending problem. Can it be due to the order of sprites?

  • I've only ever seen artifacts like that on tiledbackgrounds. Do you have any shading/WebGL effects on (just a thought, although I have no idea how that could or should cause this)? Is it just that one instance or does it happen in other places on the game? If you post this in the bugs section I think the first question you'll get asked is to check if your graphics driver is up to date. The only other thing I can think of is to suggest you try turning WebGL off/on and see if that makes a difference as well. As Hardty said, it looks like a bug, so it might be worth posting in that forum with a capx example for Ashley to have a look at.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Colludium As far I know I am not using any shading/webgl effects and my graphics driver should be up to date, but that is something I might check out. It's not on this only occasion, as soon you start moving it comes and goes, but always at the same sprite. With other sprites there's no problem. But will check this later and if the problem stays I will report it in the bug section. But first will try some of your suggestions. Thanx.

  • Somehow sorted the problem, well the problem is still there but managed to hide it. It's caused by the animation, the sprite it was most noticeable was the second frame in still position, by removing the first frame, the annoying line dissapeared, how ever it's still slightly noticeable on other animations. Might report it as a bug, first will play through more levels of my game since there are tons of animation in there. See if I can spot more.....

    A game in a game

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)