Platform tutorial issue

  • Hi! I apologize up front, but I've done my due diligence and can't seem to find another post with this issue.

    My question is regarding this tutorial and an issue I've found....

    https://www.scirra.com/tutorials/243/bu ... ide/page-1

    I've went through it, and it almost works perfectly. But the issue I'm having is very specific and hard to explain. The character seems to be "stuck" in the run animation after having jumped from one platform (rather "solid") to the next. So at its most basic, the character's animations trigger correctly - it stops after clearing the jump. BUT, if I take my finger off the arrow early (after clearing the jump - in other words, the button isn't held to the full extent, but enough to clear the gap between platforms), it still triggers the run animation and you'll see the character running in place after landing. I'm sure it's a timing thing, but I have no idea how to overcome it. I hope this makes sense!

    Thanks everyone who may be able to help out. <img src="{SMILIES_PATH}/icon_e_smile.gif" alt=":)" title="Smile">

    UPDATE - The issue was resolved by following this tutorial, which was a little more in depth..

    https://www.scirra.com/tutorials/253/ho ... ame/page-1

    I can't explain why exactly (yet). But I believe it has to do with including more conditionals (sub-conditions).

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If I have to guess, you probably have competing global events (not subsidiary to any other events) that are competing. They will trigger at the same time when they are both true and will cause... unexpected things to happen. Make sure all of your conditions are predicated on something specific so that you prevent things from executing wildly.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)