0 Favourites

Pin and unwanted dragging

  • ok so in this game i have this neat little idea concept of armor that would get damage and change animation until it disappear. After reviewing and splicing other Swf files and studying the effect various of people. I saw that they were using multiple layer of sprite and pin to the body part. So i have my main body which has one arm pinned and then a shoulder pad pin to the arm.

    Problem is every other armor pieces work just fine except for the shoulder pad....It just lagg behind like a rope effect and then drag back to the pinned spot...and this only occur during movement of the platformer behavior

    And I am dead curious if it the limit of pin as in the pin of a pin cannot work properly ? or is it some weird bug with pin behavior because it is the only one that is giving me this problem.

  • Check origin spots of the pinned obect and the object it is pinned to (check all frames if animated)

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Hi,

    Perhaps you have an imagepoint issue on your sprite animation. Check which Imagepoint you are spawning your shoulder pads onto just before the "PIN", then check the sprite to see if the imagepoint is where you expect it to be. If most of the pieces of armour are working it sounds like the shoulder-pads are simply misaligned when you pin them.

  • That cant be cause i created all the body part and armor pieces using piskel and realigned them on the editor layout before the pin...another thing is that I can swing the arm all day long and no drag effect.

    Another note is that all the sprite are roughly the same size so placement shouldnt be the issue.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)