0 Favourites

Opening/Closing small menu(popup) not working?

  • I am trying to open/close a menu when a button is clicked. The menu is set to "Invisible" initially, and when the button is pressed, it will be set visible. If the button is pressed and the menu is visible, it will be set visible. However, it isn't working. If I have only one of these set, it works, but as soon as I add both for opening AND closing it doesn't work.

    Here is the event sheet:

    I am new to construct but not to programming so I'm pretty sure my logic isn't off, I just don't know how it works yet.

    Edit: Apparently I cannot post a screenshot. I will explain my event sheet:

    on left mouse click on InventoryButton,

    if inventoryBack is not visible, set visible

    if inventoryBack is visible, set invisible

    The point of this is to be able to toggle visibility by clicking on the inventory button

  • Posting a .capx makes this so much easier. Use dropbox (you don't have the rep to post attachments).

    Welcome to the forums.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Posting a .capx makes this so much easier. Use dropbox (you don't have the rep to post attachments).

    Welcome to the forums.

    Great, thank you! I'm excited to be here. I made a tiny file where you can see the issue I am having with clicking to toggle on/off. If you toggle to disable the second event, it works (minus closing) but if both are there it does not work.

    I have no idea how to post a link with my current rep as it is. It's a dropbox link to the capx file, and the characters following the normal dropbox url (I'm sorry to do this) is

    s/ee0rbzfg56bxwkr/testFile.capx?dl=0

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)