Objects teleporting around...

  • So in my platformer, some strange thing was happening where my little Mario sprite would flash when moving and jumping. I just noticed he wasn't flashing, he was TELEPORTING -- to 0,0, to be exact, for a single frame at a time.

    I took everyone's advice and made an invisible box be the real player with the sprite just set to its coordinates, but it seems the event tying them together isn't doing its job properly. Or, of course, I screwed something up.

    EDIT: You'll also notice that the camera jumps around if you climb up the tiny hill to the right -- there's another invisible object set above Mario with the ScrollTo behavior, and apparently this teleporting issue affects that one as well.

    Anyone wanna take a look?

    db.tt/61FvHuSV

  • I've been looking at it, and it looks like there is some sort of issue with the player position when it changes between jumping and falling the position co-ordinates revert to 0,0 for a millisecond. So perhaps this is a bug and no fault of your own?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I had a feeling that might be it... I moved some of the events around and it somehow got rid of the problem. There's still some of that pesky flashing, though -- minus the teleporting -- but it only happens for a little bit when you first start it up. Thanks for the response.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)