NW.Js Unknown problem.

  • When I preview my game though construct 2 everything works perfectly fine as it should but when I export the game to Nw.js and try to launch the game though the .exe file the game won't launch but when I go back to the editor everything is fine again.

    When I made a small test game to reproduce the bug and export it to Nw.Js it launches up perfectly fine with no issues at all.

    Things you should know is that the game I'm exporting is kinda big (for me), I didn't design it to be a phone app but it has about 320 events.

    I have a few plugins installed 3rd party but I'm not sure if that is the problem and if it was the problem how to fix that but it would be strange to me if the plugins were the issue because it works fine in the preview and the person the plugins come by has a good reputation in the C2 community.

    Anyways thank you all for any idea, suggestions you may come up with.

  • Do you have "NW.js" selected as the preview browser? I'm aware that NWjs needs to use it's browser (Chrome backend I believe?) to work correctly. That's all the advice I have. I'm new here, too.

    Sorry, I mean, when you export your project are you exporting as NWjs? I'm fairly sure you need to do that for it to work, same as having NW.js as your preview browser.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • try to export with the minify script NOT selected it should work...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)