0 Favourites

Menu Troubles

  • Hi guys... Wondering what I've done wrong here.

    What I have here is a menu that comes up when I hit Esc. All elements have Anchor for a behavior. What's working - I get a Menu w/ options like Status, Equipment, etc. There's SUPPOSED to be a selection box that moves around. The selection box starts on Status but never moves, in spite of my <"Set keyboard press down arrow" Make SelectionBox Y = Selectionbox.Y+35>

    Even when I set Anchor on Selectionbox to Disabled before I try to move the selection box down by 35 pixels, nothing happens in my menu.

    Thoughts?? =(

    <img src="http://i1267.photobucket.com/albums/jj553/Dominius2010/CodeIssues.png" border="0" />

  • May be the problem you have is due to the time scale 0, set time scale to 0 but add below "set time scale layer" of your menu to 1.

  • I apologize for my newbness but I'm unable to find where I can set the variable for the time scale of a layer.

    I was able to figure out what was causing my strife with the SelectionBox, strangely enough. When I add "Set Anchor Disabled" just above "Set Y of selectionbox +35" and I DO NOT re-enable the anchor, all seems to work okay... <sigh>

    So now I'm able to move through the initial window, but on to my NEXT problem, which is Inventory.

    Tokenat isn't doing what I want it to do. I'm running a loop to generate a list of items, but the ItemName text isn't setting right from a long list of attributes.

    I'll post screenies of the code in just a second here, and even if you don't reply to this thanks VERY much for attempting to help!!

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I'm sorry, I know this is super tiny! I tried to get rid of irrelevant info...

    <img src="http://i1267.photobucket.com/albums/jj553/Dominius2010/Issues.png" border="0" />

  • In case anyone who sees this issue is curious, it seems that arrays have their own version of the loop which solved my problem. The loop is through the array and is "For Each XYZ"

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
55 14,327
cingee's avatar
cingee
Unread hot topic
0 Favourites
[PLUGIN] Circle Menu
39 7,017
Nabu0001's avatar
Nabu0001
Unread hot topic
0 Favourites
Trouble with pseudo Z axis
34 2,736
Arcticus's avatar
Arcticus