0 Favourites

Layout and same code sheet.

  • Okay, I'm having a problem with 2 layouts with the same code sheet;

    I use the action "Go to Layout Game 2" and then I set "Layer 1 set Visible"

    But the Layer 1 set visible seems to only work for the past Layout.

    1-Is there a way to remove a layout to obey a code sheet. Isn't "Go to Layout" supposed to do the job?

    2-Ah friend of mine was trying to play my game. Several friends got it working, but this one got a bug. There is one layer, where the tiled background + some sprites dissapears. But other sprites on the same layout still there.

    3-This one I got some clues. I want to add some logo (like scirra logo) on bottom of my game screen. How do I do that ? HTML index editing?

    And also wanted to set my layout screen to start on center of the page, and not on top-left corner. I guess those are HTML issues.

    Thx for the answer over the other topic. Forum is highly active.

  • 1, not sure unless I see a capx or printscreen of some code.

    2, it's probably to do with his computer not having updated graphica drivers or something.

    3, yeah HTML pretty simple, I'll post an example in the morning.

  • 1) A layout is set to work with an event sheet. You can see in the layout properties the Event sheet property that allow you to chose the event sheet that will be executed for the current layout.

    If both layouts have the same event sheet, then you have set their event sheet property to use the same event sheet.

    Check it out because creating a layout without event sheet set this property to (none) by default.

    2) He has to update its browser and graphic card drivers.

    3 a) How to customize the exported html5 index.html

    3 b) Set unbounded scrolling to yes in the layout properties if you are using the fullscreen modes. Else it may indeed be a matter of HTML.

  • Center thing was answered over other topic.

    Just select the "Unbounded scrolling".

    Here's the part of the code.

    When I trigger the end sprite. I still can see the old layout for some seconds, then it turn all to black screen.

    I Know this goes to the Layout Game 2. All of Game 2 layers are invisible,but it shouldn't,as I set Layer Level(1) to be Visible.

    <img src="http://img31.imageshack.us/img31/9102/duvidab.png" border="0" />

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • oh damn, the crazy guy with levels in layers :D

    hmmm I think in event 12 all the thing you do on layers after the 'Go to layout "Game"&Game_Layout' won't be taken into account after you change layout.

    But I can't help more, you're capx isn't easy to understand

  • 1) A layout is set to work with an event sheet. You can see in the layout properties the Event sheet property that allow you to chose the event sheet that will be executed for the current layout.

    If both layouts have the same event sheet, then you have set their event sheet property to use the same event sheet.

    Check it out because creating a layout without event sheet set this property to (none) by default.

    2) He has to update its browser and graphic card drivers.

    3 a) How to customize the exported html5 index.html

    3 b) Set unbounded scrolling to yes in the layout properties if you are using the fullscreen modes. Else it may indeed be a matter of HTML.

    Thx.

    And both layouts were already set to share the same event sheet.

    The problem is that, Going to one layout, and trying to manipulate it's layers doesn't happen.

  • oh damn, the crazy guy with levels in layers :D

    hmmm I think in event 12 all the thing you do on layers after the 'Go to layout "Game"&Game_Layout' won't be taken into account after you change layout.

    But I can't help more, you're capx isn't easy to understand

    They are taken, because I hear the Sound.

  • It does.

    But the code has to be in "Start of layout" to work of course.

    As it is screenshoted, you go to a next layer, and keep executing actions on the previous layer/layout.

    The logic of execution is wrong, you should organize your code differently. Good luck ^^

  • It does.

    But the code has to be in "Start of layout" to work of course.

    As it is screenshoted, you go to a next layer, and keep executing actions on the previous layer/layout.

    The logic of execution is wrong, you should organize your code differently. Good luck ^^

    Yeah, now this works:

    <img src="http://img546.imageshack.us/img546/6632/duvida.png" border="0">

  • Congratulations <img src="smileys/smiley1.gif" border="0" align="middle" />

    Your event sheet won also a bit of clearness it seems. A few actions disappeared, that's always good <img src="smileys/smiley1.gif" border="0" align="middle" />

  • You really should not use layers for levels! Construct 2 is not at all designed for this to work, it's amazing if it works at all!

  • In fact, it's running pretty well.

    But I still got the bug with invisible background + sprites.

    2-Ah friend of mine was trying to play my game. Several friends got it working, but this one got a bug. There is one layer, where the tiled background + some sprites dissapears. But other sprites on the same layer still there.

    More people who tried to play it, reported me that.

    I Don't think their browser is not updated. One of them was using Firefox 8. Don't think its graphic cards issue either.

    This is the game:

    goo.gl/Rq13L

  • More people who tried to play it, reported me that.

    I Don't think their browser is not updated. One of them was using Firefox 8. Don't think its graphic cards issue either.

    Then it is a problem in your code.

    Also last up to date version of firefox is 9.0.1.

    Sure FF8 is "good enough" but that proves that your users are not up to date as you seem to assure it.

  • There is no way(I think) this is a code problem.You set layer visible, and somehow some sprites disappears.

    One of them was using FF 9.0.1 and got the same problem.

    Then he tried Chrome, and got it working.

    Maybe it's something with the ZOrder, seems that the top most sprites still visible.

  • ZOrder as in zorder plugin ?

    If so, it might indeed be a bug, but it should be reported in the topic of the plugin to its author.

    3Rd part plugins are not supported by Scirra in the sense that they did not create it so won't maintain it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)