HTML 5 Exported Game facing loading issue[Solved]

  • hi ,

    Our game is fully developed & have been working on Android & IOS but when we just tried to export the same game using HTML 5 exporter & uploaded it to our test server the game stops at loading screen & didn't go any further ??? I am not getting the point as where is the problem as the game is only 6mb in size & still facing this issue ???

    Have anyone faced such issue after exporting a html 5 exporter ?

  • What does the browser error console say?

    You need to investigate the error messages the browser provides, which could indicate such things as unable to load images, MIME type issues, cross-domain security issues, etc.

  • Just checked the console for errors .......

    and I am facing Cross-Origin Request Blocked ???

    What is the solution for this ???

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Just checked the console for errors .......

    and I am facing Cross-Origin Request Blocked ???

    What is the solution for this ???

    CORS is not a C2 thing - it is a browser security feature.

    You can read about it HERE.

    Basically, you need the server to allow cross demain access.

  • I have solved almost all error ...........

    But there are two images rather spritesheet that are not loading & its showing error on console ........

    Also I see this error which I am not able to solve yet "f.prototype.ws/a.onerror()"

    does anyone have any idea as how to solve it ...........

    I am using the latest version of construct 2 that released two days before .........

  • I added few lines in .htaccess (that soled COR problem)

    <FilesMatch "\.(php)$">

    <IfModule mod_headers.c>

    Header set Access-Control-Allow-Origin "*"

    </IfModule>

    </FilesMatch>

    and have to rename two images that where creating problem as i have used "_" while name those two images ...........

    Thanks strange but it worked !!!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)