0 Favourites

How to prevent flickering on TileMaps

  • Hey guys,

    i just noticed that a TileMap (or Graphicse in general?) starts to flicker if it is made of 1px lines. I don't think that i am the first person who noticed that so i guess that it is a common problem. Is there some kind of magic trigger in construct 2 (like pixel-rounding) or do i need to have my lines thicker?

    I created an example in case its not clear what i am talking about:

    (use arrow-keys to move)

  • I tried something different, but found the same problem.

    https://drive.google.com/file/d/0B8o9UW52GFNZNXplZ1F3Nm85QXc/view?usp=sharing

  • I just noticed that the flickering nearly disappears when turning off WebGL. Turning on "Pixel Rounding" also seems to help but only on TileMaps containing a few Tiles. But that can't be the solution, right? Did i something wrong or is this an Construct 2 issue?

  • This appears to be a bug with Seamless render mode - turn it off to see the difference. Can you post this as a bug report, following the guidelines, so that Ashley can take a look?

  • I just noticed that the flickering nearly disappears when turning off WebGL. Turning on "Pixel Rounding" also seems to help but only on TileMaps containing a few Tiles. But that can't be the solution, right? Did i something wrong or is this an Construct 2 issue?

    Not only tilemaps.

    In tilebackground also occurs.

    The size of the layout and the screen influence the problem.

    If the layout is less than 800 x 600 the problem does not occur.

    Perhaps this is to be a very large layout with a far far.

    The pixels are very small and the screen can not "render".

  • martdsam yeah, i noticed your example with a tiledbackground. it even flickers with a single sprite.

    Colludium turning off seemless-mode changes nothing. but it was worth a try.

    Thanks for your help guys.

    i just created a bug-report:

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • The bug-thread was closed. Ashley replied:

    [quote:25uvnxuz]

    Closing as not a bug: you're just seeing the effect of linear sampling over sub-pixel positions. This is a normal result in computer graphics.

    For pixel-perfect display, use the project settings 'Letterbox integer scale', Pixel rounding on, and 'Point' sampling.

    I tried those settings but the situation got even worse. after loading the example only vertical lines are shown. and if i move around those vertical lines start to flicker and sometimes disappear completely leaving a blank screen. also when using "Letterbox integer scale" the resolution is a lot smaller.

    so my bug ticket was closed and i still have no clue what is going on here...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)