0 Favourites

How do I Get rid of these creases?

  • I Have created some 64/64 pixel style blocks, but when i put them together is a 32/32 grid they have creases between them and don't fit properly? Any one know how to solve this? The block i have created uses all 64/64 pixels in the editor, and i have made sure the canvas is 64/64.

    Thanks in advance.

  • Look at your sprites in the editor. If they do not fill the editor box and have a clear line around them that is your problem.

    You can cut them and reduce the size of the editor box and repaste them and that usually fixes the problem.

  • Look at your sprites in the editor. If they do not fill the editor box and have a clear line around them that is your problem.

    You can cut them and reduce the size of the editor box and repaste them and that usually fixes the problem.

    Hi, thanks for the reply,

    but the editor box is full.. as you can see in the screenshot below. It's baffling me.

  • look at all the sprites. May not be on that one.

    Are you stretching the sprites and how are you setting them in place?

  • I've checked them all, it's almost like there is a pixel of space between each new sprite i put down.

    I am putting them down as sprites (so i can set collision polygons)

    But before this, i was putting them down as Background Tiles, but i still had the same problem. Creases in between each block i put down.

    if i put a block down and activate the grid and make it bigger, it's fine, no spaces in between blocks.. only when i put a new Sprite or Tole down it doesn't completely fit seamlessly.

    Is this a feature maybe just to let you know they are seperate blocks.. i'm really not sure.

  • This is what it looks like when i zoom in REALLY far..

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I've checked them all, it's almost like there is a pixel of space between each new sprite i put down.

    I am putting them down as sprites (so i can set collision polygons)

    But before this, i was putting them down as Background Tiles, but i still had the same problem. Creases in between each block i put down.

    if i put a block down and activate the grid and make it bigger, it's fine, no spaces in between blocks.. only when i put a new Sprite or Tole down it doesn't completely fit seamlessly.

    Is this a feature maybe just to let you know they are seperate blocks.. i'm really not sure.

    What is the size of the blocks in the editor and in the layout?

    Look at the sizes because those sometimes jump around and may have to be reset.

    If you are using set to grid to set them that could be the problem.

    If you can post a capx I will look at your layout.

  • This is what it looks like when i zoom in REALLY far..

    That looks like they are being stretched.

    Can you post a capx and I will look at your layout.

  • soirry mate, what is capx?

  • it is worse when i make them bigger.. But i thought that was the whole idea of tiling?

    When i make them small again there is only a little crease as opposed to the big blurry one before.

    But does that then mean i need to copy and paste the same sprite 100 times to make a level?

  • I have just seen that when i run the game it looks like the creases are gone.. But would they come back if the game gets closer by any chance?

  • soirry mate, what is capx?

    A CAPX file is a file of your game saved as a single file.

    I can load that and look at your layout to see the problem.

    It looks like they are being stretched which is probably a sizing issue. That gets worse when you stretch them more.

    If they look fine in game play it is probably your snap to grid settings not matching the tile settings.

    I really can't help more without seeing a capx sorry.

  • > soirry mate, what is capx?

    >

    A CAPX file is a file of your game saved as a single file.

    I can load that and look at your layout to see the problem.

    It looks like they are being stretched which is probably a sizing issue. That gets worse when you stretch them more.

    If they look fine in game play it is probably your snap to grid settings not matching the tile settings.

    I really can't help more without seeing a capx sorry.

    oh i get ya now. How should i send it to you?

  • You can upload it to and then PM me the link and I will look at it.

  • You can upload it to and then PM me the link and I will look at it.

    not enough rep to pm. i'll post is here though pal. And delete shortly.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)