0 Favourites

How do I get Appodeal working on my app?

  • Hi all! I'm trying get Appodeal working on my app. So far, I've download the Chrome extension/addon. I've logged into Appodeal/created an account. Now, I clicked on 'Enable Admob reporting', and I got this message...

    Basically, from here, what should I do next?

    Also, at this point, should I have uploaded my app APK into the Google Play Developer's Console already?

  • Bump......

  • I need to know if my app has to be uploaded on to the Google Play website (with Admob working) first, before I can even begin the Appodeal setup process?

  • I've now placed the appodeal folder from archive (SDK) to your Construct 2\exporters\html5\plugins folder. What do I do next? How to I get my "appKey"?

  • To link my Admob account to my Appodeal account, do I need to type in my app's "ID" into where it says "Project Name" in the picture above?

  • Bump...

  • BUMP.... To link my Admob account to my Appodeal account, do I need to type in my app's "ID" into where it says "Project Name" in the picture above?

  • guannstar

    Login at appodeal website, admob website and google developers website.(console.developers.google.com) At the same time.

    Click on chrome extension and run every step. Chrome extension should connect admob with appodeal and develooper console. It is a script that runs almost automatically. (sometimes you need to do a few clicks) Then you need to create app on appodeal website, right there you will be given appkey. Go to c2, right click and add AppodealPlugin, click on it and set that appkey to the AppodealPlugin (inside of c2).

  • Hey Arclight (thanks), I did what you said, and it seems to have worked, there's just one thing.... my build keeps failing (more details can be found in this post: ). Do you know why this keeps happening?

  • guannstar

    Well, first of all im using cocoon, so i can't really help.

    But i suggest reading these:

    scirra.com/tutorials/4896/simplest-appodeal-tutorial-high-ecpm-earning-ads

    scirra.com/tutorials/4866/how-to-integrate-ads-into-intel-xdk-android-apps-crosswalk-high-ecpm

    And one more thing.

    One of the guys who helped me said: in appodeal's instruction there is a step where you need to add appodeal plugin from github to xdk. But after intel's update game won't compile if you do so. But if you wont add plugin to intel, then it should work. And you will be able to see ads. (Translated from russian. Hope you can understand this)

    Glad to help

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Hi!

    You not needed to write this project name manually. Plugin will be do it automatically. I recommend to delete project that you have created manually and restart plugin again

    Hope tis works

  • Hey, thanks Natx... but what do I actually write in the three 'git repo' spaces (or am I supposed to be using the 'Cordova plugin registry', like I did)?

  • In theory you have two options:

    1. Using officiall Appodeal setup.

    • C2 Appodeal's official plugin:
    • Then In Intel XDK you have to add two plugins:

    *

    *

    2. Using cranberrygame Appodeal setup.

    • C2 plugin is within Cranberries plugin pack
    • Intel XDK plugin:

    The problem is that I have just tried both and I can't get any to work. With the official Appodeal setup I can't build an app. It gives compilation error.

    With Cranberrygame's setup I cannot even add the plugin in Intel XDK.

    Can someone who managed to set it up put some light on this situation please?

  • The problem is that I have just tried both and I can't get any to work. With the official Appodeal setup I can't build an app. It gives compilation error.

    With Cranberrygame's setup I cannot even add the plugin in Intel XDK.

    Can someone who managed to set it up put some light on this situation please?

    I suppose that the problem might be in libraries, if you've tried to edit them or in DEX files, cause if u're using lots of them there can be some limits on permissions. Anyway I'd suggest contacting their support directly and explain the problem, they have live chat on home page so it won't take long

  • BackendFreak 2 days ago I used v 1.14.6 and worked, now v1.14.9 also give me error in IntelXDk

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)