0 Favourites

How do I fix this?

  • A week ago I published a few games I made with Construct 2 and exported via crosswalk to the Google Play store. Today I received the following warning:

    Security alert

    "Your app is statically linking against a version of OpenSSL that has multiple security vulnerabilities. You should update OpenSSL as soon as possible.

    The vulnerabilities were addressed in OpenSSL versions beginning with 1.0.1h, 1.0.0m, and 0.9.8za. To confirm your OpenSSL version, you can do a grep via ("$ unzip -p YourApp.apk | strings | grep "OpenSSL""). For more information about the vulnerability, please consult http://www.openssl.org/news/secadv_20140605.txt.

    To confirm that you've upgraded correctly, upload the updated version to the Developer Console and check back after five hours.

    Please note, while it's unclear whether these specific issues affect your application, applications with vulnerabilities that expose users to risk of compromise may be considered "dangerous products" and subject to removal from Google Play."

    Anybody know what this is and how to solve?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Search 'openssl warning' in the forums and you'll find several threads talking about it. No point repeating it all here But you should be able to rebuild to get rid of the warning by choosing crosswalk version 'beta' (crosswalk 10).

  • Awesome, thanks.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
175 32,640
clifton11221's avatar
clifton11221
Unread hot topic
99 10,149
karshinkoff's avatar
karshinkoff
Unread hot topic
98 7,598
norum82's avatar
norum82