0 Favourites

How do I Fix problem with tiled background

  • I had the background working perfect but after a lot of problems arose with the layout size I was using I decided to increase my layout size to a 16:9 ratio of H:1024 & W:576, and adjusted all the graphics and sprites to match the new size.

    Now the background when the game begins leaves a gap at the top of the screen and because it is supposed to wrap to layout also leaves a gap when the background comes around again. I have tried to set the position of the background at the start of layout using set x y but it seems to override this and go to where it was before.

    The only bit of code I have referring to the background is bullet speed 200 and angle of motion 270 as I was it to scroll upwards constantly due to the game being an infinite faller.

    Any ideas or advice would be appreciated!

    StrangeyD

  • without seeing the code it becomes guesswork.

    you said it overrides a new x,y setting ? I guess you have a bit of code that says when the background reaches a certain point then move it back to another point - this might need checking. Using tiled backgrounds - this will need setting to the correct size (a multiple of the tile used) or you will end up with it not joining correctly.

    Any chance you can post/link to your capx ?

  • I think I have set the tiled background to the wrong size after the new layout changes im going to see if that is the problem, thanks for your reply if I cant fix ill post the capx.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I have resolved the problem, it was because set to angle was on in the tiled background properties, so it was displaying at angle which is why the gap was appearing.

    Thanks for your reply's.

    Mods feel free to close this thread.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)