0 Favourites

How do I correct the preview colour issue

  • Hi guys!

    Can anybody see the same thing I'm seeing? When I import my sprite, the colours look fine. In the layout and the sprite screen, the colours are nice and dark. As soon as I preview in Chrome, the colours suddenly appear bright.

    Can someone tell me what I'm missing? Have I turned a setting on by mistake? I added a random image of a GIF apple, and that looks fine. Is it the fact that my animation is using PNGs?

    Updated link

  • save as single file and update your link

  • Yann is right, a .caproj file is just a list of other files in the project, and you haven't included any of them - make sure you save as a .capx which has everything.

    Monitor callibration/colour correction can affect colours, I've seen the same happen in Firefox too - not sure there's anything we can do about it, it seems the browser decides what colour correction to apply.

  • Sorry about that. I've updated the link. The apple image appears to retain the colours, but the png animation doesn't. Wondering if I've done something wrong somewhere along the line.

  • It seems like your sprites were somehow at fault

    try these UFO.zip

  • Thanks, Yann. It's somewhat worrying though. I rendered them directly from 3DS Max. Going to need to play around with the settings it seems. I assume you re-saved the frames from within Construct?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Nope I opened them in photoshop and batch saved them

  • I wonder what I did wrong then...

    Rather than open up a new topic, can I ask another question here, or should I really open up a new one for each query?

    I'm wondering how to set up the collision polygon. Is there a quick way to do it for each frame in an animation in one go? At the moment, I have to go through each frame and tell it to guess the shape. Is there a one-click solution to this? I tried the apply to other frames button, but that just duplicates the current shape.

  • I have had the same problem when rendering from MAX - it seems to store the gamma settings in the files, also some extra DPI info as well. When I import the files right into C2 they are often brighter AND the wrong size even when you click the 1:1 button. Meanwhile most other programs display them properly. I suspect the PNG importer is a tad too good in C2, taking into account too many options.

    Edit: +1 on the automated one-click generation of collision masks. When you have dozens of frames it's a real pita to go through all of them and generate new collision polies.

  • Thanks Somebody! ...weird writing that... :)

    I do recall seeing a gamma setting during rendering. I will go back and check that!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)