0 Favourites

How do I... add a new achievement?

  • For some reason anytime I add a CLAY I/O achievement it just hangs and never loads the layout (even if it's a simple layout w one sprite).

    Is there something I need to add before (or after) the Award Achivement to make sure it will load the layout?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Hmm, it's not right at the start of your game is it? Clay takes a second or two to load, so you have to put the early commands in the event: "Clay.io Ready" or it will cause a Java error leaving the game hung on a black screen before the progress bar even appears.

    Most of it's commands require a small wait, and have "on ready" events for those too. but Setting achievements usually is a set and forget. It will pop up a little window on its own after contacting the server to see if that one has already been achieved.   

    It could be another Java error when you award the achievement, are you sure you have the API key set in the Clay Properties? (do other Clay features work?) Java errors usually show in preview mode, not not on exported projects.

    Edit: Oh, and "Clay.io Ready" only fires once, so if you want to check again later, have it set a globle variable. Then you could add a check of the global variable to the setting achievement event, so it won't fire if it's not ready.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)