0 Favourites

Having Troubles with an climbing ledge animation

  • Hi!

    I've been having troubles for already 2 days trying to get the climb animation to work. Actually what happens is that the Player first goes up to the top of the tile (New X, Y position) so the animation is played not while climbing but instead on the new position. I'm sorry I cannot post a capx file since I'm quite advanced in my prototype. Hope the screenshots can be of any help.

    Thanks in advance!

    Code in Player Animations:

    Code in Player Controls:

  • Nevermind

    Actually I completely forgot to check the origin point location. Thanks

  • Actually, having another small issue with this. Again, sorry if I don't post a capx since I'm too advanced in the development of my prototype.

    The issue is: Currently the origin point of the grab_ledge animation is set at the center bottom of the sprite and then during climb_ledge animation I switch it to the top of the sprite. I'm having a small ghost frame in-between that seems to move down really fast and then go back to the position (top of the ledge). The frame moving weird seems to be grab_ledge one.

    Thanks in advance.

  • It's pretty difficult for me to fix this without testing and I see no1 else is responding so it's not just me. You got 2 choices now, fix it yourself or find someone trustworthy that is willing to help you. I would go for the first option, it may seem impossible to sometimes, but there's always a solution.

  • Just out of curiosity, why are you moving the anchor point mid-animation?

  • Because I haven't found a better way to do the climb_ledge properly brunopalermo

    @Remus B I know there's always a solution. I just want to avoid making people load a bigger file size which uses many plugins they might not have installed.

    I'm simply trying to understand what might cause this or if someone else had the same issues.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Definitely not a good idea... But without a capx it's hard to come up with a better one.

  • I move one of the image points of the animated sprite and not the PlayerDetect. I also used this on a cinematic platformer with no issues.

    also, actually resolved this by simply forcing the first frame of the climb animation in place. Now works perfectly.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
1,941 263,182
FlyingRam's avatar
FlyingRam
Unread hot topic
65 14,825
qvatra's avatar
qvatra
Unread hot topic
0 Favourites
How do I do climb down
36 1,307
FraktalZero's avatar
FraktalZero