0 Favourites

Error loading project

  • Hi all, first of all, I wasn't sure if this was a bug, or just a simple error. So I'm posting it here.

    Well, the problem is that when I try to open one of my projects, this error appears:

    Error loading project

    ---------------------

    Failed to open project

    \\?\C\Users\...

    Cannot find object texture fie "Player_tank_smog" in the project texture folder. Check the file has not been removed or renamed.

    Under element: c2project \ object-folder \ object-type \ line 268, column 9

    The file maybe invalid. Try checking the file in a text editor (Projects are saved in XML format).

    -------------------------

    OK

    But I really didn't change/remove anything!

    I was working on the project a few hours ago, saved it as usual, closed C2 as usual, went away and came back after a few hours as usual, tried to open it... and this error appeared.

    PS: I'm using C2 r126 Steam

    PS 2: The address that this error shows me, doesn't exist in windows actually!! And it changes every time I try to open the project (Weird?).

    Please help me, I had worked days and nights on that project, it was a nice thing really.

    [Thanks for reading]

  • Please help me guys! Or at least give me a conclusion about what the problem is/might be!

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • when I have bugs like that I just try using different things to do what i'm trying or rearrange it

  • But I have exactly no idea about what the problem is! And besides, I cannot even edit the project nor rearrange it, since I can't open it.

  • I have had this also, luckily i just reloaded an older save and lost 20 mins of work...

    I think it's looking for a temp directory that your project is stored in when editing, If you have system cleaning software sometimes this can delete files in this directory I believe, do you not have a recent back up, to go back to?...

  • If it's a .capx, rename it to .zip and extract it. Now you have a folder based project.

    Create an empty image file with the name it says is missing, and the project should open.

  • If it's a .capx, rename it to .zip and extract it. Now you have a folder based project.

    Create an empty image file with the name it says is missing, and the project should open.

    Wow thanks!! It worked!! Thanks again!

    I have had this also, luckily i just reloaded an older save and lost 20 mins of work...

    I think it's looking for a temp directory that your project is stored in when editing, If you have system cleaning software sometimes this can delete files in this directory I believe, do you not have a recent back up, to go back to?...

    Well, no. I didn't really do anything special. Unfortunately I didn't have copies of it but luckily, I could have it back, special thanks to Ashley!! <img src="smileys/smiley1.gif" border="0" align="middle" />

  • Hi.

    In which folder did you place your missing image? I am having the same issue.

  • Ldk

    This thread is nearly a year old

  • I know. Found the correct folders eventually. Had to create a new project and save it as a project. I have always saved all my stuff as a single file and havent seen any folder structures.

    Managed to recover 6 hours of work.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)