Enemy is not moving as I expected, any help?

  • So, here are the events I setted up for my "Enemy",

    is just really random and basic, to see how it works.

    <img src="http://s12.postimg.org/rt0ooa3fx/events.png" border="0" />

    I created a sprite called "Mob",

    then created an instance variable called "MobMov" and setted to start with the value "derecha" (right).

    The sprite also got platform behaviour with default control set to off.

    <img src="http://s7.postimg.org/o8doi1uvv/atts.png" border="0" />

    So my intention was to generate a mob near my character every second (just to see if they spawned), and that was the first problem, it just spawns 1 mob. Not more.

    Then the idea was to randomly move left-right every 1 to 10 seconds,

    so if the mob was walking to right, every 1 to 10 seconds it would change and walked left.

    But it appears, go right, a second later go left, and then never goes right again.

    So..

    what am I doing wrong? xD

    Thanks! :)

    EDIT:

    "Mover" is the playable character,

    and "Block" is the ground.

    So Mover.X is where my character is on X range.

    And Block.Y-100 is to generate it above the ground,

    and fall to ground.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I feel so stupid,

    saw the picture of the events,

    and notice that there's just 1 "every x seconds" event,

    and the others are "set time".

    There's my error,

    so sorry for making a non-sense thread. xD

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)