0 Favourites

Email, with attachments $_POST problems, with multipart

  • Hi

    I have posted the tutorial

    Sending basic email works fine from C2 with my method in the tutorial above, but someone has requested if you can do email with attachments.

    Now, I have got this working with PHP alone, multipart header and base 64, but when It comes to getting the $_POST from c2 it comes out with an array() blank.

    I can't figure out what is wrong.

    I will post a screen of the code below, maybe someone can help?

    If you subsitute the $_POST for an email address..i.e..."someonessomewhere.com" it works.

    Obviously, We can do this with 3rd party plugins (mandril etc), but reliance on 3rd party is always suspect to future change

    cheers sizcoz

  • Anybody ?

  • I am a bit stumbled on what exactly your issue is, is it to get the Post value "email_to" be an mail address when posting from Construct 2?

    Or is it to read the output of the php in construct 2?

    If the issue is to get construct 2 to send out an mail address we will need to see the construct 2 part.

    But yeah a bit stumbled on what exactly is the issue, hopefully you can clear that up for me and il be more than happy to help you out!

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I am a bit stumbled on what exactly your issue is, is it to get the Post value "email_to" be an mail address when posting from Construct 2?

    Or is it to read the output of the php in construct 2?

    If the issue is to get construct 2 to send out an mail address we will need to see the construct 2 part.

    But yeah a bit stumbled on what exactly is the issue, hopefully you can clear that up for me and il be more than happy to help you out!

    kentbakk

    Its getting the $_POST['email_to'] variable from c2, it does not seem to appear when I run the php script, I am using the same method that I used in the tutorial I posted, the capx is here, ,

    I can send an email without attachment with the method in my tutorial, and send an email with attachment with this script above, if I change the POST value to, for instance "sizcozsomewhere.com";, but the POST variable from c2 does not show?

    Many thanks in advance for your reply

  • > I am a bit stumbled on what exactly your issue is, is it to get the Post value "email_to" be an mail address when posting from Construct 2?

    >

    > Or is it to read the output of the php in construct 2?

    >

    > If the issue is to get construct 2 to send out an mail address we will need to see the construct 2 part.

    >

    > But yeah a bit stumbled on what exactly is the issue, hopefully you can clear that up for me and il be more than happy to help you out!

    >

    kentbakk

    Its getting the $_POST['email_to'] variable from c2, it does not seem to appear when I run the php script, I am using the same method that I used in the tutorial I posted, the capx is here, ,

    I can send an email without attachment with the method in my tutorial, and send an email with attachment with this script above, if I change the POST value to, for instance "sizcozsomewhere.com";, but the POST variable from c2 does not show?

    Many thanks in advance for your reply

    Okay i see, il do some testing and come back to you

    Could you send me the php code in text format tough?

  • >

    > > I am a bit stumbled on what exactly your issue is, is it to get the Post value "email_to" be an mail address when posting from Construct 2?

    > >

    > > Or is it to read the output of the php in construct 2?

    > >

    > > If the issue is to get construct 2 to send out an mail address we will need to see the construct 2 part.

    > >

    > > But yeah a bit stumbled on what exactly is the issue, hopefully you can clear that up for me and il be more than happy to help you out!

    > >

    >

    > kentbakk

    > Its getting the $_POST['email_to'] variable from c2, it does not seem to appear when I run the php script, I am using the same method that I used in the tutorial I posted, the capx is here, ,

    > I can send an email without attachment with the method in my tutorial, and send an email with attachment with this script above, if I change the POST value to, for instance "sizcozsomewhere.com";, but the POST variable from c2 does not show?

    > Many thanks in advance for your reply

    >

    Okay i see, il do some testing and come back to you

    Could you send me the php code in text format tough?

    ok pm me your email, and i will send it.

    Thanks again

  • [quote:1wqfc3bq]ok pm me your email, and i will send it.

    Thanks again

    You can send it to

  • [quote:rerby95a]ok pm me your email, and i will send it.

    Thanks again

    You can send it to

    Sent.

    Cheers

  • Hi guys! Attachment method works? It's important for me.. Thanks!

  • sizcoz Thanks for the tutorial. Does it work on an app? The tutorial looks like it supports on a website.

    I'm completely new for this, so this might be a silly question.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)