0 Favourites

creating multiple instances of sprite with diff im

  • I am making a game similar to jigsaw puzzle where i need to create puzzle pieces with different images, co-ordinates , etc and put in some form of scrollable selection container/controller.

    It doesn't make sense to create static sprite as there a lot of images 100 images x 20 puzzle pieces each = 2000.

    Just wondering how to do it to create several dynamic instance of sprite with a different image every time it loads the new puzzle image.

  • i am thinking of using this plugin anime unique plugin [URL=http://www.scirra.com/forum/pluginunique-spriteno-animuniqe-image-per-inst_topic43116.html , but unfortunately it seems to be only avaiable for .csx classic construct, has anyone has ported to .js plugin or any other ideas to implement ? <img src="smileys/smiley25.gif" border="0" align="middle" />

  • try putting all the different puzzle pieces into one big animation, and when you create it, you can call the different animation by frame number

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I am using ur same suggestion and trying to create 10 objects on start layout event, but it seems to get executed for every tick not just once , not sure what happens, but please help . Here is the CAPX dl.dropbox.com/u/80050021/PHTrial.capx

  • Can i get some help here, i know it might be a silly question, but people like me with little programming experience trying to work out something after all i guess Contruct 2 is created to help people like me :)

  • Your problem has nothing to do with the creation of the sprite instances!

    First, you should give people time to responde - at least a day I would say.

    Second, you should try to keep your code clean from random trials of different techniques and plugins not used.

    Now, after I managed to get something to show - building effect masks does not realy show something - I could see what's going wrong. You have set your "default" sprite, which you recreate with "system create" to auto start and loop through your different frames going back and forth every 5 frames. This creates the illusion of haveing the "start of layout" code to be executed "every tick"!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
0 Favourites
Sprite Font Generator - v3
368 112,330
RetroDaddy's avatar
RetroDaddy
Unread hot topic
86 28,714
St4rDu57's avatar
St4rDu57
Unread hot topic
153 104,446
DravenX's avatar
DravenX