0 Favourites

Another problem with Saved games

  • I'm having a problem with saved games. I followed the tutorial how-to-make-and-name-save-game-slots

    If I start a game and save, it works, as long as the browser is not closed and the session is still active. As soon as I close the game/browser and re open it The game just gets stuck. PlayerBox spawns at the top of the layout and doesn't load properly.

    Any help would be appreciated. I just can't see where I'm messing up. Thanks in advance <img src="smileys/smiley1.gif" border="0" align="middle">

    EDIT** Here is the CAPX file as I am still unable to get it working properly.

    CAPX File

  • bump^

  • ^Bump

  • The pic isn't showing and your explanation of your problem is vague.

    Since you're following a tutorial, try PM'ing the author directly.

  • Thanks inkBot fpr replying, the Author hasn't been on the site for last 2 months. Didn't realize there was a problem with the pic. I will make a Capx and post it asap.

  • The problem is, when I Restart my browser the saved games no longer work but when I save a game and keep playing the save feature works and I can reload to an earlier layout with all the correct values restored from the save game.

    When the Browser is restarted, that saved game does not load properly, the playerbox does not drop to the ground like it should and the values for score and lives say "NAN".

    Here is the link to the CAPX file, if anyone can help. I tried to minimize it as much as possible.

    CAPX File

    Thanks in advance

  • You are useing WebStorage! Does your browser purge cookies if closed?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Thanks for Replying.

    No, all my settings in Chrome are default and the problem occurs regardless of what browser I test in.

    I have got it to spawn the character at he first checkpoint now but for some reason the game won't recover the score, lives and layout or it keeps forcing layout 1 and I can't see what is doing it. Any other Ideas?

  • IMHO I doubt that anything really gets stored. If you use CHROME you could get the extension "Edit this cookie" to get access to the saved cookies.

    When I hit save in your game, no cookie gets created....

  • Thanks for following up Weishaupt, what you said in your last post made me think of something. trying it now will post back if it works.

  • A closer look at the cookies retrieved the following:

    CREATE TABLE ItemTable (key TEXT UNIQUE ON CONFLICT REPLACE, value BLOB NOT NULL ON CONFLICT FAIL)

    ...so it seems to be an error in your code!

  • You're not loading the ArrayPow array. When you click the load button you set Layout to ArrayPow.At(1,2) and VX to ArrayPow.At(2,2) etc. but you haven't loaded the ArrayPow array from webstorage so all thoses values are 0.

  • Thanks ramones and Weishaupt, I finally got it working. Much appreciated <img src="smileys/smiley41.gif" border="0" align="middle" />

    To get it working I needed to clear storage, then I disabled the ArrayPow actions from the save button and the system > set ArrayPow from the load button and it works now.:)

    Final question, how would I load ArrayPow from Webstorage? I looked at the manual and I'm still confused. Sorry for the noob questions. Regardless it's working well from what I can see, I just want to understand better. Thanks again , both of you:)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)