0 Favourites

[Cocoon] Can't login to Google Play Games

  • Hello, the other day I added support for Play Games Service from Google in my Android app I have in the Play Store, so I could add leaderboards and achievements.

    I downloaded and installed Cocoon's plugins in C2, and I added CocoonAds, CocoonCanvasPlus and CocoonGooglePlayGames in the project.

    In the loading screen I created this action:

    On start of layout + Is Canvas+ = Request login.[/code:14faonb3]
    I have another way of login in, via a button on a optios menu, in case the first login failed:
    [code:14faonb3]On tap gesture on button + Is Canvas+ = Request login.[/code:14faonb3]
    After that, I exported the project with Cordova, using this options.
    Finally, I upload the zip (without the config.xml and intelxdk.config.additions.xml files, as I saw in a tutorial) and proceed to set up the app information in Cocoon.
    Then I add all the plugins I use, and I make sure I add the APP_ID. (censored in pick)
    I sign the app, and compile it. Then, I upload it to the Play Store as a beta update (I have it enabled in the Games service).
    I download th egame from the Play Store, launch it, and when the login stuff starts, it shows me the Connecting screen, and the loading spin.
    Then I get back to the game without the Welcome user! popup and nothing happens, even a little image I added in case the login fails, appears.
    Is there something else I need to do? Should I reinstall the plugins, or create another app or game service? It worked the frist time I tried the plugin, but after some time, it stopped working. I even tried uninstalling the game, and deleting the game and Google Play app cache.
  • Hi,

    I saw your comment on my youtube video.

    Have you setup your Google Play service completely on google play? also have you released the game service?

    Otherwise it won't work.

    You also can add your email to the testers and activate the game service only for beta / alpha testers. Then you do not need to publish the game service first.



  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Hi,

    I'm a bit late but I have the same problem here. I read and followed the tutorials i saw but i can't find where the error is

    I'm trying to add a leaderboard in my game but i can't even log in (i have the same result than Marxaly). I just see the pop up with the name of my game and "trying to connect" and it disappears from the window...

    My game is in beta phase and i added well the application's ID in the plugin, I have released the game service . And of course i can't open the leaderboard because i'm not logged in.

    Please, i rellay need help

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)