Windows 10

  • Just been playing around in Win10 10130.

    Spartan:

    C2 projects fail to load - blank screen.

    Also Spartan will not go full screen -at least I cant find anywhere to tell it to.

    Thanks for this info!

    To MS and Spartan/Edge devs: Boooo!

    I have not been brave enough to try out W10 because the upgrade will delete my C drive when the real version is released. Good info you have there - I wonder if this is a Spartan/Edge bug or a C2 export setting that's at fault. I have confidence that if it's C2 then Ashley will fix it asap; however, my confidence is somewhat less if the problem lies at MS' door. I'm almost tempted to load a version of W10 just to try it and get on with submitting bug reports.

    Edit to add: with a release date of 29 July I am not so sure this will be fixed in time...

  • Edit to add: with a release date of 29 July I am not so sure this will be fixed in time...

    Yeah I have just put 8.1 back on (running a SSD and don't have enough room to run both side-by-side).

    EDIT: started the install after posting the above browser info!

    Just don't have enough time to keep farting around with lots of niggly issues that are there atm. (some have been around since the second build was released and still aren't fixed.)

    Overall I quite like it, and will definitely buy a copy when released, but definitely won't sacrifice my 8.1 key on the free upgrade MS is offering.

    With W10 going public end of July they sure have their work cut out for them! I suspect service pack1 will be hot on its heels!!

  • I've done a bunch of testing in Edge and everything worked great. I've not run in to any problems yet.

  • i've bought lumia 930 like a few days ago. call me crazy but that phone owns.

  • Would be great if it works on Xbox.

    Does the new Browser (Edge) only run on Win10 or is there a Win8.1 Version?

  • Yeah, I would think MS wants everyone to move to 10, so I doubt that Edge will be available for any previous flavour of Win.

  • I've done a bunch of testing in Edge and everything worked great. I've not run in to any problems yet.

    Hi Ashley, for me any project, even a blank one fail to load. After about 30 seconds Edge displays a page that says 'localhost 50000 can't be reached right now' or something similar.

    IE runs fine though.

  • i've bought lumia 930 like a few days ago. call me crazy but that phone owns.

    Windows phones are great!

    If you are eligible, I recommend you check out DevMov by Microsoft. You can get free stuff by making Windows apps. You can get a Surface Pro 3, among many other prizes

  • Ashley

    I discovered this problem too on my build... confused the life out of me.

    I'm using a Windows 7 machine with IE11. running from the C2 it runs fine, but when exported and uploaded, it freezes. I went into the debugger console and there's nothing wrong there. I changed the browser emulation from EDGE to 10, and it started working.

    I'm not sure how to dig through the full programme as it's only the uploaded version with the issue and not the "run layout" version. If you have any pointers on how to track the problem down, I'll go digging. The console is not reporting any errors.

    As it stands, this is a major problem. I'll not freak for the moment as I'm sure it will be fixed..

    Found some more information...

    Creating AppCache with manifest: 'http://XXX.XXX.XXX.XXX/nebula_rebuild/offline.appcache'.

    AppCache Fatal Error

    WEBGL11135: getContext: Context attribute depth:false is not currently supported

    Error loading image 'http://XXX.XXX.XXX.XXX/nebula_rebuild/images/galaxy_enemies-sheet0.png': [object Event]

    Error loading image 'http://XXX.XXX.XXX.XXX/nebula_rebuild/images/galaxy_enemies-sheet0.png': "

    [object Event]{AT_TARGET: 2, bubbles: false, BUBBLING_PHASE: 3, cancelable: false, cancelBubble: false, CAPTURING_PHASE: 1, constructor: Event {...}, currentTarget: HTMLImageElement {...}, defaultPrevented: false, eventPhase: 2, isTrusted: true, srcElement: HTMLImageElement {...}, target: HTMLImageElement {...}, timeStamp: 1434912294476, type: "error"}

    for information, if I go to the image referenced there, it exists.

    I hope this makes more sense to you than to me

    R

  • Ashley, I did a bit more digging... and I had protected my dev-site with a .htaccess control.

    removing the htaccess controls allowed the game to run. somehow the permissions granted to access the index.html and other scripts did not follow through to the sub-directories.

    given that, I suspect it could be more to do with the edge engine than the C2 code.

    R

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ashley, I did a bit more digging... and I had protected my dev-site with a .htaccess control.

    removing the htaccess controls allowed the game to run. somehow the permissions granted to access the index.html and other scripts did not follow through to the sub-directories.

    given that, I suspect it could be more to do with the edge engine than the C2 code.

    R

    I just loaded up Windows 10.

    I am getting a blank page (page not found) when testing my apps in browser for both Spartan (edge), IE, and Firefox.

  • Ashley, will teh WIndows 10 updates only include changes in the pubCenter and IAP plugins?

    I read MS has introduced Video Ads & Interstitial Ads in pubCenter. It will be great if Scirra team can have these basic plugins ready for stabel version. Also as you work on the IAP plugin, request you to include IAP consumable feature

  • If anyone has any issues with any C2 features on Windows 10/Edge, please file a bug report following all the guidelines or it will not be investigated.

  • i'll be sure to test everything out when i upgrade in a couple of days. Everyone please file a bug report, so we can get things fixed, if anything is not working!

  • Ashley pubCenter plugin works with windows 10 ?

    a test it in visual studio but not show advertising.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)