0 Favourites

Why does my game lag since now?

  • UPDATE: Ok, so only the debug mode seems to get hit by the FPS drop. I know that the debug mode needs more resources but it still ran with 60FPS this morning. But anyway, I can live with a fluent game in normal mode and a laggy debugger.

    Hello,

    this morning my game ran without a prob at 60 FPS, I saved and closed the file. Now I wanted to continue working on it but noticed that the FPS dropped to 40-50 without me changing anything. I tried to restart my laptop, cleared my browser cache and cookies, tried to run it in node-webkit. No improvement what so ever. My game is very CPU light, since it is going to be for mobiles. As I said, I didnt have this problem this morning and constantly tested my game before.

    Only plugin I use is for Spriter and Construct 2 version 170

    My rig:

    Intel I7-4700MQ 2.40GHZ

    16GB RAM

    Nvidia Geforce GTX 770M, Intel HD Graphics 4600

    Windows 8.1

    performance picture: dropbox.com/s/hp3vvvxaye3izbs/performance.jpg

    Does anyone have any idea? I mean something must have changed!

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Sorry to hear that Allchix. I actually had something similar happen to me. Suddenly all the files from just 1 project started to lag very badly when it normally ran very smooth. Tried restarting the C2 but it was the same. But everything went back to normal once I restarted my computer.

    If you didn't update or change any of the settings in C2, could it possibly be from an external factor? Did you update any other softwares or programs on your computer prior to the problem.

    I hope your problem goes away soon like mine. Hopefully someone with more knowledge in this will be able to help you.

  • I'm wondering if this at all relates to the issue that I started having recently? https://www.scirra.com/forum/performance-issues-stutter-in-chrome-out-of-nowhere_t106103?

  • I have the same issue since update 170. Only I dropped from 60 on all my devices... to 30 constant and spikes to 10.

  • I also got a performance drop on my test device. So I ran a test.

    1 image of 512x512. stretched to fill a 640x480 res. With a text box for fps. There is nothing else. Not a single line of logic.

    Went from 60fps to 48fps. So what I found was that when the image is smaller it runs better. When the image is stretched the fps is dropped. It seems that WEBGL seems to have Canvas like rendering in regards to performance loss :\

  • jayderyu, Wow, that is very interesting! It sounds like something Ashley and his team might want to know.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)