0 Favourites

What is the best compiler for C2 233 ?

  • Hi, I always use xdk but seem the latest ver xdk3491 can't compile project from C2 233 (ios/android) anymore.

    so please advise alternative compiler for it.

    Thank

  • Can you elaborate on your problem? What error do you get?

  • ERROR (-7) from "client:upload-manager": Error in zipping package asset files: : Error in zipping config files: : Error in generating Build Config files: . Error at new ComponentError (C:\Users\keng pc\AppData\Local\Intel\XDK\xdk\core-modules\public\component-error.js:17:1122) at makeError (file:///C:/Users/keng%20pc/AppData/Local/Intel/XDK/xdk/components/client/upload-manager/upload-manager.js:17:170) at getComponentError (file:///C:/Users/keng%20pc/AppData/Local/Intel/XDK/xdk/components/client/upload-manager/upload-manager.js:17:265) at file:///C:/Users/keng%20pc/AppData/Local/Intel/XDK/xdk/components/client/upload-manager/upload-manager.js:17:21767 at _rejected (file:///C:/Users/keng%20pc/AppData/Local/Intel/XDK/xdk/node_modules/q/q.js:844:24) at file:///C:/Users/keng%20pc/AppData/Local/Intel/XDK/xdk/node_modules/q/q.js:870:30 at Promise.when (file:///C:/Users/keng%20pc/AppData/Local/Intel/XDK/xdk/node_modules/q/q.js:1122:31) at Promise.promise.promiseDispatch (file:///C:/Users/keng%20pc/AppData/Local/Intel/XDK/xdk/node_modules/q/q.js:788:41) at file:///C:/Users/keng%20pc/AppData/Local/Intel/XDK/xdk/node_modules/q/q.js:604:44 at runSingle (file:///C:/Users/keng%20pc/AppData/Local/Intel/XDK/xdk/node_modules/q/q.js:137:13)

    I try to ask XDK forum they told me need back to ver3400

    Why C2 staff team not update engine match with latest XDK.....

  • i'd tell you that the best one is visual studio with cordova, but many will say it's not because it's a bit more complicated to work with...

    if you got the time to work it out...

  • try cocoon.io

    https://cocoon.io/

    or simply back to xdk 3400 and C2 r232.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Why C2 staff team not update engine match with latest XDK.....

    They just did with the latest beta. You might want to file a bug report if you can't export any project.

    Did you export it with the Cordova option from C2? Did you use new XDK format?

  • > Why C2 staff team not update engine match with latest XDK.....

    >

    They just did with the latest beta. You might want to file a bug report if you can't export any project.

    Did you export it with the Cordova option from C2? Did you use new XDK format?

    Dude I already report to staff but they told me report to XDK >>

    Did you export it with the Cordova option from C2?

    • Yes.

    Did you use new XDK format?

    • Yes.

    My question why c2 staff team not test latest build before release it completely not work with xdk3491 I must back to XDK3400.

    And...Wkwebview never work since C2 -227 when try to install plugin my game always crash after splash screen.

  • Interesting.. Does it make any difference if you do it the "old" way: export without the new XDK format and import it into XDK?

    I think they do check the currently available version of XDK when they release a new update. This can either be an error with the newest XDK version (if I recall right, it was released after the C2 beta update) or with your project. But it seems to be the first one.

  • Interesting.. Does it make any difference if you do it the "old" way: export without the new XDK format and import it into XDK?

    I think they do check the currently available version of XDK when they release a new update. This can either be an error with the newest XDK version (if I recall right, it was released after the C2 beta update) or with your project. But it seems to be the first one.

    Did you test game with wkwebview on ios ?

    All release since C2 227 release note said wkwebview work but actually it never work !!! May be c2 staff never test on XDK, it worked if test on cocoon.

  • Had the same issue. Couldn't export anymore. You should remain with the 227 version of C2 and 3400 of XDK.

  • Had the same issue. Couldn't export anymore. You should remain with the 227 version of C2 and 3400 of XDK.

    You can use C2 233 it work find on xdk3400 but wkwebview not work (Actually it never work according to release note said)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
0 Favourites
Spriter/C2 - Spriter 2 Teaser!
1,800 322,207
tarek2's avatar
tarek2
Unread sticky
763 305,673
asikanddestroy's avatar
asikanddestroy
Unread hot topic
0 Favourites
Your C2 tests
566 243,737
thisisblogs's avatar
thisisblogs