What admob plugin support new intelXDK R3088 ?

  • For old intelXDK i use phonegabadmob by cranberrygame work very well but seem not working with new intel XDK R3088 (got popup plugin error when import to intelxdk).

    So please advise what C2 admob plugin support new intelXDK any free or paid Thank !

  • me too, it just simply doesn't work, even importing it in this XDK build has error.

    It is official as of now 2016-March-26 Admob in Construct 2+XDK is BROKEN.

  • It is official as of now 2016-March-26 Admob in Construct 2+XDK is BROKEN.

    It's not, official AdMob plugin works just fine.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • The problem is NOT with Construct 2, it is with the latest build of Intel XDK.

    Use XDK Build 2866 WHILE YOU STILL CAN and it will work PERFECTLY.

    [Source: I tried it, spend hours with the latest Intel XDK thinking it was my fault or Construct 2 or AdMob's, last resort download older version of Intel XDK and WORKS LIKE A CHARM!]

  • Been using latest XDK since it was released and had no problems with it. Just need to be sure to add third party plugin ID using "cordova-plugin-ad-admob"

  • shinkan, internally INSIDE construct 2, it access the plugin by the id: com.cranberrygame.phonegap.plugin.ad.admob

    Sure you can add it with no problem by adding it via another id in the latest XDK Build, but try making the ad ACTUALLY show up.

    [PS: It will STILL WORK on the latest build PROVIDED you build it from an earlier XDK Build, then the latest build will leave the previous Admob id alone, then everything will be ok, how do I know ? I tried, it works. BUT you must FIRST build it with an earlier version of the XDK first.]

    This is a XDK Bug.

    You MUST get your hands on XDK Build 2866 while you still can and while it is STILL supported.

    Hopefully Intel XDK will be fixed soon...again.

    They make it good, they broke it, they make it good...the cycle continues...

  • It is not a bug and won't be fixed. If you read latest Intel XDK release notes you will understand. The way plugins are fetched is different now and developers have do the upgrade, but phonegap afmob from Cranberrygame is deprecated and probably won't be updated. You have to use Cranberrygame Cordova AdMob plugin now in Intel XDK.

    @Shinkan the one you use is not the one from the official manual.

    Ibelieve Scirra will update manual soon.

    You may want to check my related post here

  • It is not a bug and won't be fixed. If you read latest Intel XDK release notes you will understand. The way plugins are fetched is different now and developers have do the upgrade, but phonegap afmob from Cranberrygame is deprecated and probably won't be updated. You have to use Cranberrygame Cordova AdMob plugin now in Intel XDK.

    shinkan the one you use is not the one from the official manual.

    Ibelieve Scirra will update manual soon.

    You may want to check my related post here new-intel-xdk-version-released_p1024788?#p1024788

    Where I download C2 Cranberrygame Cordova AdMob plugin + Cranberrygame Cordova AdMob library plugin ? And it free or paid plugin ?

    Another question C2 plugin offical & C2 Cranberrygame Cordova AdMob plugin, which one is better ?

  • You can use official C2 plugin with cordova ID as Shinkan suggested. Then it is free, but I had screen freezes sometimes.

    For compatibility reasons I suggest using C2 Cranberrygame Cordova AdMob plugin. However it is not free, but extremely cheap. You can buy all Cranberrygame plugins in one pack. Check Scirra store.

  • It is not a bug and won't be fixed. If you read latest Intel XDK release notes you will understand. The way plugins are fetched is different now and developers have do the upgrade, but phonegap afmob from Cranberrygame is deprecated and probably won't be updated. You have to use Cranberrygame Cordova AdMob plugin now in Intel XDK.

    shinkan the one you use is not the one from the official manual.

    Ibelieve Scirra will update manual soon.

    You may want to check my related post here new-intel-xdk-version-released_p1024788?#p1024788

    Did you even TRY to compile Admob for iOS using the latest XDK Build before you say so casually that it is not a bug ?

    Let me put this to rest with PICTURES !

    The latest version of XDK/AdMob Combi is a DISASTER.

    http://imgur.com/7YJyhXA

    I also have to disable WKWebView because it is causing all kinds of compilation errors with the latest version of the XDK.

    I am so going to NEVER USE XDK again after this project, I am SICK and TIRED of them CONSTANTLY .... just CONSTANTLY breaking their own software.

    Check out their LATEST FUCK YOU stunt:

    Using EXACTLY the version they want you to use and still says please use the version that you have already selected.

    It is like the bully that ask why are you hitting yourself.

    Public Service: Build 2866 of Intel XDK STILL WORKS WITH AdMob and iOS, QUICKLY DOWNLOAD THIS EARLIER BUILD WHILE IT IS STILL WORKING!!!

  • If I remember correctly, some time ago Cranberrygame changed id from com.cranberrygame.phonegap.plugin.ad.admob to cordova-plugin-ad-admob. so basically I am using the official one... It's just the manual states the wrong one and manual update cycle is terrible (updated usually on every C2 stable release).

    @Toddler Unfortunately I don't use xdk for iOS because don't care about them at all, so I'm sorry but can't help you with that :/

  • Did you even TRY to compile Admob for iOS using the latest XDK Build before you say so casually that it is not a bug ?

    Well you didn't mention at start that you have problem with iOS. No I haven't tested iOS. I thought you mean Android cause some people already reported problem for Android as well.

  • Pictures changed that debate pretty quickly.

  • It sure did.

  • If I remember correctly, some time ago Cranberrygame changed id from com.cranberrygame.phonegap.plugin.ad.admob to cordova-plugin-ad-admob. so basically I am using the official one... It's just the manual states the wrong one and manual update cycle is terrible (updated usually on every C2 stable release).

    Toddler Unfortunately I don't use xdk for iOS because don't care about them at all, so I'm sorry but can't help you with that :/

    The manual may NOT got it wrong after all, because that old admob id STILL works with the older build of XDK.

    I am telling you, XDK is broken...again.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)