0 Favourites

Unnecessary Lag

  • This is my first post so I would like to say hi to the community and after a brief look construct seems very promising <img src="smileys/smiley1.gif" border="0" align="middle" />

    I have a problem though, my computer experiences a drop in frame rate when the object count goes over 10. My first attempt at a game is a platformer with multiple solid platforms, they may be overlapping, as they are generated dynamically, is this an issue? The lag is experienced whether the platforms are generated dynamically or placed manually.

    I have a laptop with the following specs:

    2gig nvidia 335m

    2.4 x 4 intel i5

    4 gig ddr2 ram

    win 7

    Which I doubt is the problem as on a little laptop resolution there is almost no modern game I can't play on highest or near highest graphics setting.

    I have tried both the latest version of firefox and chrome, which both support hardware accelerated html5 (i think).

    I have played a few games on the site's Arcade with no detectable lag issues.

    Any suggestions as to why is my computer struggling so much?

  • If you share the *.capx file which you have the problem with, it would help a lot.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I'm drawing 21000+ objects... that could be why <img src="smileys/smiley9.gif" border="0" align="middle" />

    My first time using construct today. My problem is I didn't have a for loop as a sub event, so it was run every tick.

    Thanks

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
85 7,286
shimo's avatar
shimo
Unread hot topic
36 2,498
fiepaper's avatar
fiepaper
Unread hot topic
32 3,772
megatronx's avatar
megatronx