0 Favourites

Two Node-webkit problems still on v.168 [Temp Freeze fix!]

  • Would like to know if others are having these issues.

    First is the freezing issue. Like on

    Subscribe to Construct videos now

    at 1:43. That is quite short but it can be longer and usually is about 4-6 sec.

    Second issue is with some Blend modes. If you download THIS example and you try it in browser (tested Firefox and Chrome) it works as intended, but on Node-webkit it doesn't work if WebGL is enabled just shows black. Should be that blue background with some white lines.

    Im using C2 version 168 64-bit

    Could these be bugs or something else.

    For anyone who's suffering from NWK freezes after exporting, try reverting back to 0.8.6, as it is working for us.

    LINK:

    https://github.com/rogerwang/node-webkit

    Under downloads, Prebuilt binaries (v0.8.6 - Apr 18, 2014): win32

    Remove your game.exe, extract the file to your node-webkit exported project (replace remaining files ), and that's it! You can rename the exe file.

  • I've noticed freezes recently in r161 as well, but couldn't be sure if it was related to Node-Webkit or something else.

    Sometimes using preview or export game can freeze at the beginning. But after closing and restarting every thing works fine.

  • I also made simple example where there is just a box with physics behavior falling down and it's then destoyed and spawns a new one. This is also doing the same thing.

  • I sometimes also have freezes like that. I though it was an issue with my code (a memory leak or something). I haven't realize it could come from a Node-Webkit bug.

    So this topic interests me!

  • I also made just very simple box falling experiment and it does the same thing.

  • I'm not sure why node-webkit shows a black background, but it's related to the layer's destination-atop blend mode. If you change that it works OK.

  • Ashley, I was messing with the blend modes for the effect that the light draws over player but not the background.

    Is there another way to make that effect for Node-webkit.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Ashley, the freeze that I told you is exact the same in the Katala 's game. I noticed that the engine also have a memory leak and it could have something to do about it.

    Katala did you fix it? I tried many things, but the freezing is still there.

  • Yes there a freeze when export with node webkit, not when preview.

    my layout game is big but without enemies or any thing that will harm the fps.

  • arcgen, No. I don't think there is a lot I can do.

    First this seems like a small thing, but I imagine it might be very frustrating on multiplayer games. Just thinking could it be the GC pile up stuff a bit too much and then removing it takes a bit too long. These freezes seems to be longer when it haven't done it in a while.

  • Ashley, it looks like there are more people having the same freezing problem. Could it be garbage collection or something after the Node-webkit exporter on windows?

    Katala, not only on multiplayer games. Imagine a single player match and you are jumping or trying to do something, but the game froze for 5 seconds. It's really, really bad.

  • arcgen I dont have to imagine :/

  • Ashley, it looks like there are more people having the same freezing problem. Could it be garbage collection or something after the Node-webkit exporter on windows?

    Katala, not only on multiplayer games. Imagine a single player match and you are jumping or trying to do something, but the game froze for 5 seconds. It's really, really bad.

    Sorry for bumping this thread up but has this bug been fixed yet with the freezing problem or is there more information out there how to fix this?

    With a project i'm currently working on I have a freezing problem and I can't seem to figure out what the problem is and how to fix it. The game freezes at random intervals for about 2 to 4 seconds. When it happens it seems very random and not when a particular event/action is happening. This makes it even harder to find out why it happens. Sometimes it doesnt happen while playing for 10 minutes long but it can also happen after 80 seconds or after 30.

    It also depends on which system I play it on, it seems to happen on the windows platform but not on Macs with the node-webkit exporter. Atleast thats my experience so far. I'm starting to think its a problem with the export and with windows. But I can also be totally of about that. Any information is welcome

  • I don't think it's anything to do with Construct 2. AFAIK games run smoothly on other platforms, so it sounds like a node-webkit issue.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)