0 Favourites

Tizen + C2 config file

  • Ashley, please could you offer some advice.

    I'm hoping to export some projects to Tizen via appBackr, using Tom's "Create WGT File" tutorial!

    However, I wanted to test the apps before submitting to appBackr. So I've also worked through your tutorial, for exporting to Tizen!

    Unfortunately every time I've tried to run the project through the SDK, I receive an error on the C2 generated config file. But If I copy across everything except for the C2 generated config file, the project seems to work!

    Does this indicate a problem with the C2 generated config file, or a bug in the Tizen SDK? Does appBackr, make any changes to the config on their end, is this why it doesn't seem to work initially?

    I'm happy to submit my .wgt files to appBackr! But I wanted to make sure everything is working properly, before I do!

    Thanks for reading this, any help you can offer would be greatly appreciated.

  • Blacksmith

    I had a similar issue.

    I solved by using the basic web app template config.xml file created using Tizen, and then I made the appropriate changes for my app.

  • simwhi, thanks for the reply.

    I had thought about creating my own config file!

    But I'd still be interested to see what Ashley thinks. After all, if you just need to recreate the config file anyway, then why have it in the export in the first place?

    Also Tom 's tutorial re submitting to appBackr, doesn't mention anything about this. Does that mean lot's of us have submitted .wgt files, which won't work on Tizen?

  • My version:

    1. I have removed

                  ?<!-- This text is displayed if the visitor's browser does not support HTML5.

                  ?You can change it, but it is a good idea to link to a description of a browser

                  ?and provide some links to download some popular HTML5-compatible browsers. -->

                  ?<h1>Your browser does not appear to support HTML5. Try upgrading your browser to the latest version. <a href="http://www.whatbrowser.org">What is a browser?</a>

                  ?<br/><br/><a href="http://www.microsoft.com/windows/internet-explorer/default.aspx">Microsoft Internet Explorer</a><br/>

                  ?<a href="http://www.mozilla.com/firefox/">Mozilla Firefox</a><br/>

                  ?<a href="http://www.google.com/chrome/">Google Chrome</a><br/>

                  ?<a href="http://www.apple.com/safari/download/">Apple Safari</a><br/>

                  ?<a href="http://www.google.com/chromeframe">Google Chrome Frame for Internet Explorer</a><br/></h1>

    from index.html because propably it gave me warning from Tizen Store (      [Defect] The application contains an incomplete URL (http://www.google.com/chrome/)]

    2. I have updated index.html with this viewport:

    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no, target-densitydpi=device-dpi" />

    result: Web Simulator shows correctly Landscape

    3. I left only 117x117 icon (circle) made in Tizen IDE, just as Tizen Store said to me

    ([Defect] 1. Launching icon is not a circle. 2. Launching icon size is not 117 x 117 pixels. - The policy of icon size has been changed from 108 x 108 pixels to 117 x 117 pixels. 3. Registered icon in the Tizen seller office is not a circle.)

    4. I have added feature to config.xml

    tizen.org/feature/screen.size.normal.720.1280

    tizen.org/feature/screen.size.normal.480.800

    (in other case your WGT will be rejected during WGT upload to Tizen Store)

    On the 2nd time my app was accepted

    but verily it would be nice if C2 would generate better output files

  • szymek

    Very useful information. Many thanks.

  • Yeah thanks szymek, this is really helpful stuff.

    I'd still be interested to hear a little more about the C2's config file though!

  • Yea, this is very helpful ! I'm going to try it!

    Hope real device will meet our expectations !

  • We've made some changes to the config.xml file that C2 generates for the next build. Hopefully everything will work more smoothly when the next beta is out.

  • Great! Is the new beta coming out anytime soon, by any chance? I'm going to a Tizen jam on Friday.

  • Thanks for the advice Ashley, that'll be really helpful!

    Hey ChrisAlgoo, hope you enjoy the jam! It'd be great to hear more about it, when you're done :)

  • Sure thing! There's prizes; I hope to win one :)

  • Ashley Thanks for this.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • szymek

    I have made all the changes to my Tizen projects. All seems well with no errors or warnings. However, my game that is in landscape mode does not work correctly in the web simulator but is fine when run in the Tizen emulator.

    Any ideas?

    Also, I have not managed to find a solution to loading json files via an AJAX request. I have removed <access origin="*"/> from the config.xml file for the time being, and used string literals to store the json data.

    I can also report that Back button functionality works, as well as local storage.

    I'm now feeling confident in submitting our games via AppBackr.

    Thanks for all the info.

    Simon

  • simwhi

    no ideas :) Landscape in config.xml + this viewport update + Browser > lock landscape = Landscape in my Web Simulator

    I can't check emulator propably because AMD Cpu and this Intel software wasn't installed

  • Rejected! Oh, I'm expected smth like this, but what this mean ? The failure log is just lot string of code. Like :

    "...I/TZAUTO ( 2809): virtual void ConnectionManager::OnSocketReadyToReceive(Tizen::Net::Sockets::Socket &)(184) > ISRUNNINGAPP#CSGoyMX8Ja#

    I/TZAUTO ( 2809): bool MessageHandler::ProcessMsg(Tizen::Base::String)(129) > _MessageHandler::ProcessMsg() called

    I/TZAUTO ( 2809): Message *MessageHandler::ParsingMsgN(Tizen::Base::String)(839) > ParsingMsgN ISRUNNINGAPP#CSGoyMX8Ja#..."

    Title:

    [Function] Failed to install application

    Result:

    [Defect]

    The application has failed to install. Please check the failure log.

    [Test Procedure]

    Install application.

    [Expected Result]

    1. The application must be installed properly without causing any errors.

    2. After installation, the launching icon should not be overlapped or distorted, and should appear clearly.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
0 Favourites
Spriter/C2 - Spriter 2 Teaser!
1,800 322,233
tarek2's avatar
tarek2
Unread sticky
763 305,693
asikanddestroy's avatar
asikanddestroy
Unread hot topic
0 Favourites
Your C2 tests
566 243,739
thisisblogs's avatar
thisisblogs