0 Favourites

Tilemap & sampling:point are not working?

  • I don't know if i'm doing something wrong but i have this differences between tilemap and sprites:

    TILEMAP

    SPRITES

    In both cases i'm using sampling point but it's not applied in tilemaps, here an example with sampling linear:

    It's a problem with tilemap object? there is a solution? because i can't make a tile-based game drawing tiles with sprites, the performance is not goood

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I just did a quick test comparing a sprite, tiledbackground and tilemap, all using the same image, and I couldn't tell the difference.

    Would it be possible for you to post a very simple .capx so others could test for you?

  • Here is your example modified with my parameters. Tilemap at right, sprites at left, all with sampling: point

  • Here is your example modified with my parameters. Tilemap at right, sprites at left, all with sampling: point

    To get tilemap to work correctly (the sampling) your tilemap should be in the power of 2 dimensions. I remember Ashley mentioned this somewhere. You are using [24x24] so thats why its like that.

    Use 2^1=[2x2], 2^2=[4x4], 2^3=[8x8], 2^4=[16x16], 2^5[32x32]... and so on.

    Sorry I didn't test, but I'm sure thats the problem, because it was discussed a few times previously.

  • I can see the difference now, but as DuckfaceNinja mentions, and the manual entry says,

    [quote:8c051et8] It is recommended to use a square power-of-two size (e.g. 32x32)

    so try that, and if it still looks fuzzy, then post a bug report for Ashley.

  • Thanks, i tried with 32x32 tiles and worked! I thought that the power of 2 recomendation was because the images are saved as power of 2 size anyway, but clearly affects to display too

    Sorry for my english.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)