0 Favourites

Tiled Background problem

  • When two different tiled backgrounds are touching or overlapping, a thin white line is formed like this:

    dl.dropbox.com/u/4759481/Tile_problem.png

    I have tried to work around this issue, but it always seems to eat up much of the time I should use to create my game.

    If the darned engine need to create a line between the tiles - why not a transparrent one that can't be seen???.

    To me - this is by far the worst thing about C2 and makes it very hard to make a professional looking game.

    I really do hope somebody has a solution to this - or at least a work around. :)

    Thanks!

  • I don't have any problems. If you are using Construct2's image editor, it leaves 1px space if you crop or resize with it.

    It's hard to tell what the problem might be without seeing the capx.

    Does turning pixel rounding help in project settings?

  • Construct 2's image editor does not add a 1px space to tiled background images.

    This is an issue with how GPUs draw tiled textures, and is not specific to Construct 2, you'll have this problem regardless of what tool you use. Usually it's caused by sub-pixel positioning or non-power-of-two textures. At the moment only power-of-two size textures can be tiled perfectly and seamlessly (the image editor should warn you if using a non-power-of-two size). Also, enabling 'pixel rounding' in project properties will prevent sub-pixel positioning so seams never appear, but it could make scrolling a little less smooth.

  • I don't have any problems. If you are using Construct2's image editor, it leaves 1px space if you crop or resize with it.

    It's hard to tell what the problem might be without seeing the capx.

    Does turning pixel rounding help in project settings?

    Why would you wan't 1px space between your tiles? I would like them to just touch without any gap between.

    A background looks pretty silly with 1px line between the tiles...

  • Construct 2's image editor does not add a 1px space to tiled background images.

    This is an issue with how GPUs draw tiled textures, and is not specific to Construct 2, you'll have this problem regardless of what tool you use. Usually it's caused by sub-pixel positioning or non-power-of-two textures. At the moment only power-of-two size textures can be tiled perfectly and seamlessly (the image editor should warn you if using a non-power-of-two size). Also, enabling 'pixel rounding' in project properties will prevent sub-pixel positioning so seams never appear, but it could make scrolling a little less smooth.

    Pixel Rounding and power of 2 doesn't make any difference for me, unfortunately :/

    Same problem. But It doesn't show on my AMD gfx machine and my Nvidia machine with older drivers.

    So it could be a driver problem with Nvidias latest drivers.

  • I still have like a small white line around my image with 256X256. That is square format. So than its not possible to use that as a tile background?

  • Can you post the image or .capx?

  • I'm having this problem, but only in Internet Explorer if it's set to scale mode - does anyone know of a workaround for this?

    As at the moment it makes creating anything for the Windows 8 store pretty tricky if you want to support multiple resolutions.

    Here is a capx showing the problem - preview it in Internet Explorer and adjust the window size.

    https://www.dropbox.com/s/07jitwourupus47/IEtiles.capx

  • Haematite - there's no point using tiled backgrounds like that. Just stretch one object over the whole area rather than using separate objects. It's faster and looks correct too.

  • Ashley - I'm aware that that was a poor example, but it will still occur in a situation like this:

    https://www.dropbox.com/s/xxru9raecksvefi/IEtiles2.capx

    where there is no way to avoid it if I wanted to create a pyramid for example, or any shape that is not a rectangle. Any advice?

  • If you need pixel perfect display, set Pixel Rounding to 'On' in project properties, Sampling to 'Point', and set fullscreen-in-browser to either 'Off' or 'Letterbox integer scale'. Looks fine with those settings here. Note if you use the retro style template when creating a new project those settings are already chosen for you.

  • Haematite

    You also had that capx to start in Internet explorer. Try using another browser.

  • Ashely ok, thanks for your help, I'll have a play around

    @Newt yeah, I wouldn't normally be testing in IE, but I want to export a game to the Windows 8 Store so need to test it.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Hi there guys, I�m suffering the same problem here. Even with all corrections made. Setting the project like Ashley said, and using power of two measurements for the tiles, the problem persists.

    I'm using Google Chrome to test my game btw.

  • Sorry to drag this up, but I have the exact same issue. As mentioned by pcfernandesjr, I have also followed all instructions with regards to power of 2 size (128x128), Pixel Rounding (On), Sampling (Point) and scaling (Letterbox integer scale). Still I have a white line round my tiling backgrounds. Doesn't look like there's anything to be done about this, just wanted to log it here

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
39 1,422
Zebbi's avatar
Zebbi
Unread hot topic
73 32,041
shubhamrathi9's avatar
shubhamrathi9
Unread hot topic
98 7,590
norum82's avatar
norum82