Strange Problems with audi (Music) - Pathfinding dont work

  • Hi all

    currently i am encountering very strange problems with audio, maybe someone of you guys can point me in the right direction!

    Construct2 : 196.2

    Testing with latest Chrome and latest Chrome Canary

    1) SoundFX works fine in Chrome, but with Crome Canary there are problems! Sounds stop after a few seconds, later sounds aren`t played at all. when i switch the tab and then tab back the current sound is played then it stops working again. maybe this is just a bug which will be fixed till next release

    2) Music isn`t working stable at all! i wrote the following code to enable disable music:

    pretty simple switch and random song selection...

    the following behavior apears with this:

    • first song is played fine.
    • mostly second thiong is played fine
    • after that only the 2 first played songs are played at all when the random generator pics a new song.
    • the songs who work are different with every restart
    • i cant reaload the browser window when i enable this code
    • the pathfinding only works 40% of the time
    • if i disable the code the pathfinding works fine. there are no shared variables

    NOTES:

    • in Internet Explorer Music doesn`t play at all
    • in FireFox EVERYTHING works like intended (Even reloading the page)!!!

    Those issues are really annoing, as i mainly develop for crosswalk and with those bugs i cant use music which in my humble opinion is a very basic feature... any ides or suggestions?

    thanks for your help!

    Patrick

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)