0 Favourites

Settings up ads with Cocoon + Admob + Mopub problem

  • I'm trying to get ads working on my Android app but no ad seem to appear on testing.

    I am following this tutorial (https://www.scirra.com/tutorials/781/ho ... b-cocoonjs) but can't seem to get it working.

    Here is what I'm doing:

    1. Adding Cocoon Js events to the capx

    2. Add app to admob

    3. Add app to mopub

    4. Set networked cpm to 0.01

    5. Insert admob publisher code into mopub

    6. Obtain mopub id

    7. set cocoonjs project to accept mopub ads

    8. Add mopub id to cocoonjs

    Yeah and when I compile and install the signed debug apk to my phone, app works perfectly fine but ads dont show.

    If you could help that would be cool, thanks <img src="{SMILIES_PATH}/icon_e_smile.gif" alt=":)" title="Smile">

  • When you click on network > global segment > and it shows you the list of apps and networks you need to click X on the filters tab, then it will show your inactive apps for you to select and push "run" it a weird issue that everyone on here has and doesn't know how to fix.

  • I tried it out and attempted to filter to show all of the running ads in Global segment and it showed my ads which means it is already running.

    I tested to show all iOS apps and it didn't show just to make sure (since its only Android).

    Tested again and ads still are not showing up

    Not sure what this means but it seems like it's attempting to show the ads?

  • bump

  • t33hp, I'm happy to help if I can. I'm no expert but it shows 10 requests with a zero fill rate... You might be having the same problem a few have reported of a poor fill rate - mine has gone down to way lower than it was a month ago, don't know why. If that's not it - have a look in your mopub inventory page (I think), does it show an awaiting approval message or similar. Happened to me for a week when I started, I didn't notice at first and it only got fixed when I emailed them.

  • t33hp, I'm happy to help if I can. I'm no expert but it shows 10 requests with a zero fill rate... You might be having the same problem a few have reported of a poor fill rate - mine has gone down to way lower than it was a month ago, don't know why. If that's not it - have a look in your mopub inventory page (I think), does it show an awaiting approval message or similar. Happened to me for a week when I started, I didn't notice at first and it only got fixed when I emailed them.

    I tried looking at my mopub inventory page but there seems to be nothing about approving messages.

    I just created a new account on admob + mopub and doing all the steps over again but to no success, the ads still don't work.

    How often does the Request count update and are ads meant to appear in the debug version?

    Thanks

  • t33hp,

    Looking through your code - and please understand that my experience at this is rather limited - it looks like you might have entered an incorrect or incomplete code for your AdMob reference in the MoPub setup page (the publisher id). Your code is in a very different format to mine; it's quite possible that AdMob do this depending on your region etc, but it look suspicious to me.

    To check this you need to go to MoPub Networks, click on the edit pencil next to the main AdMob link (if you click on the main link you'll then need to click on Edit Settings top right of screen). This will list your AdMob codes. The attached image shows my redacted AdMob code in Mopub - and as you can see, I have a ca-app-pub before a longer hex string than you have. Then go into AdMob and click on Monetize and then All Apps on the left side. Your AdMob Ad Unit ID will be shown here and should match what you have entered in MoPub.

    If it doesn't, I think we might have found what's wrong - just copy it and paste it over what you have in MoPub/Networks/AdMob Edit/Your App ad id.

    If it does match then I'm afraid I have run out of ideas. If it's any consolation, it took me a couple of goes and a second MoPub account to get my ads up and running...

    Looking through this again has reminded my how appallingly unintuitive and frustrating the MoPub site is.

  • I can't tell whats wrong here, everything seems fine, what CPM value have you set? And are you seeing any mopub demo ad?

  • t33hp

    5. Insert admob publisher code into mopub

    this is looking wrong... you must set there ID of your ADD and not your general ID of publisher.

    looks like this:

    ca-app-pub-xxxxxxxxxxxxxxxxxxxxxxxxxxxx

  • one C2 user added keywords (filter) to his app configuration on MoPub side, so MoPub was getting ads but not showing any because of those keywords

    maybe that's issue too?

  • t33hp

    5. Insert admob publisher code into mopub

    this is looking wrong... you must set there ID of your ADD and not your general ID of publisher.

    looks like this:

    ca-app-pub-xxxxxxxxxxxxxxxxxxxxxxxxxxxx

    That was because it was the old admob website.

    Since then I have inserted the new ID because I made a whole new account for admob and mopub.

    Ads for some reason started appearing today but they're mopub demo ads, not 'real' ads.

  • I can't tell whats wrong here, everything seems fine, what CPM value have you set? And are you seeing any mopub demo ad?

    The demo ad started appearing just today, not sure why.

    When are 'real ads' meant to appear?

  • t33hp have you double check your admob id setting in mopub like what others saying? you are suppose to get real admob ad now, even my developing ios app is seeing real ad from admob, and test ad from iad & mopub.

    if you still cant make it work, contact mopub, they do reply emails, might take 2~3days.

  • I just read the market place tab and found this message if that helps:

    Your access to Marketplace is currently being reviewed. You can enable your inventory and set minimum CPMs during this process; note that Marketplace will not serve ads until you have been approved. If you have questions, please contact .

    In the mean time I contacted mopub.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • t33hp

    in MoPub... click on the top right icon for settings and check is all green in there?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)