Screen size slow down

  • The size of the window is effecting my game. The smaller the window, the better things run. When I'm in debug mode the game runs flawless but when I do a regular preview the game slows down quite a bit and the controller becomes not as responsive.

    I've exported to node webkit an experience the same problem - bigger window, slower game and unresponsive controller. I resize the window to something smaller and things start to run better.

    Can anyone point me in the right direction to remedy this problem?

    Thanks!

  • How many objects do you have on the screen? Are the using effects, behaviors etc? It's hard to tell without a capx.

  • There are about 57 objects on screen when you start a level. Behaviors include platform, solids, rotation, sine, bullet. 2 effects are also used but just as a transition and character entrance.

  • a stated above it's hard to know if it's you project causing this problem without a capx. What kind of events are you using? Have you tried updating your GFX card Drivers? what are you running the game with(Browser)? what are you PC specs? Do they support WEbgl in your browser? what kind of downscale setting are you using in C2? what scaling?

    We can really help without this type of info as it could be anything from you have a old pc to using a nonupdated browser

  • Thank you for your replies!

    GFX card is up to date. The game is being run in Chrome and nodewebkit. WebGl is on. Fullscreen scaling is High quality. Use high-DPI display - yes- Sampling Linear. Downscaling High Quality. Physics Engine Box2d web.

    I haven't tried turning the scaling down to Low quality, I'll give that a shot.

  • When you say change the screen size does this mean the amount of stuff that can be viewed on the screen is less/more? or is it the same content just smaller/bigger?

    If it's the prior it's probably slowing down as you have more objects to render.

  • The video looks really cool. It's just too hard to know without a capx really. Try changing your downscaling to medium, that might help.

  • TheWyrm that's exactly what I was thinking but after watching the video I don't think that's the case.

  • TheWyrm its the latter - the same content just smaller/bigger. I'm just resizing the chrome browser or nodewebkit window with my mouse

  • Maybe try in debug mode and see if there's anything weird going on with your percentages when you resize.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • StraitJacketGmng yeah first thing you should try is changing the scaling the medium or low as that can effect it a great deal. even Ashley recommends using the medium setting and not the high unless needed as it consume a great deal more memory

  • Not quite sure where the problem is without looking at a capx.

    Obviously when you a have a larger screen there are more pixels to render which requires more computation. Do you have any webgl effects as they would need to do more work on a larger resolution?

    Have you made any search or resize algorithms based on screen size?

    What I normally do in this kind of situation is to make a copy of the capx and start systematically disabling bits and previewing the results in a hope to finding the cause. This at least helps to isolate the problem into a capx you can potentially share.

  • OK, seems most people here haven't experienced this problem before

    What you're most likely experiencing is a Fillrate bottleneck. Basically, a GPU can only draw at maximum a certain number of pixels every second. On desktop PC's this number is usually in the hundreds of millions [citation needed] but at 1080p with a few layers of full-screen graphics, you can run into the problem very quickly.

    For example:

    1920 * 1080 ~ 2,000,000 pixels

    2,000,000 * 60fps = 120,000,000

    Now multiply that by how many fullscreen graphics you have, layers with shaders or 'force own texture' on, etc.

    The solution to this is either to reduce the amount of fullscreen graphics, or just choose a lower window size and set fullscreen scaling to low quality.

  • Thanks again for your replies. sqiddster - that makes sense! I implemented EddyDingDongs Multiple Graphic Modes tutorial and that seemed to help a bit too

    https://www.scirra.com/tutorials/932/mu ... erformance

  • No one has mentioned the fact that all the assets seem really high res - are they optimised? Could be an asset that's like 530x530px eats up a whole 1014x1024 texture map,etc. Have a bunch of them and it quickly eats video ram and performance.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)