0 Favourites

Screen flashing with NWjs / Audio related

  • I'm not reporting this as a bug yet as I am not sure about the real reason of it. Just thought maybe someone experienced this already and could explain why this is happening.

    When I run my game with NWjs (no matter if it's preview or exported version, also no matter if it's SDK or normal version of NWjs), the screen flashes from time to time. This does not occur when I preview the game in the browser.

    All I managed to investigate is that it is related to Audio object. When I remove the Audio object, the screen doesn't blink any more. Is it possible that screen blinking/flashing might be caused by many/fast triggered audio sounds?

    Here's the video of the problem. You can already see the quick blink in 2nd second of the video:

    Ashley is this something known to you?

    PS. I use the newest NWjs version and C2 r234

  • After several tests I found out it's NWjs problem. I tried versions 0.16.0, 0.15.0, 0.14.7 and problem still was there. So I jumped back some more to the past and tried version 0.13.0-rc1 and with this version screen does not blink.

  • Alright I went one by one NWjs versions. Problems starts from version 0.14.0 and up. So it might be Chromium 50 issue or something in NWjs. Olders versions don't have this issue.

    BTW: I saw I'm not the only one with this issue:

    Ashley is this something Scirra wants to cover? I mean will you report that to NWjs or should I do it?

  • We've seen exactly this flickering problem too. We rolled back to earlier version (pre 0.14.0) of nw.js to export our Gamescom build, and it worked fine. It seems to be a Chromium issue, not nw.js. Looks like it's this problem reported to Roger Wang (nw.js) here: https://github.com/nwjs/nw.js/issues/4947 and he's stated it's upstream (Chromium) and closed the report.

    But finding the C2 Audio object might be causing it is really interesting and quite strange. BackendFreak Can you make a bug report with example capx showing that the audio object is causing it?

  • Well it's bonkers if removing audio fixes it since obviously audio has no part in the rendering engine whatsoever.

    I'd suspect this is a graphics driver bug so it might be useful to correlate it with which systems are affected or not affected and what hardware they have. Also if you can reproduce it in Chrome, it would be good to file a report on crbugs.com with steps to reproduce, the list of affected hardware, etc.

  • No I can't reproduce it in Chrome. It only happens with NWjs. I might prepare the capx later.

  • Might it have something to do with the old bug with renaming project files?

  • Just FYI: problem still occurs in NWjs 0.17.0.

    I have changed the project name indeed. What was the issue with that newt? Can you give some more details?

    Thanks

  • Nwjs changed how they set up files internally, and it caused a few issues on older saves.

    The workaround before the fix was to rename the project in C2.

  • I have also been having this issue... Should I try to roll back to version 0.13.0-rc1?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Yeah I am using v0.13.2 all the time now. Using any newer version is simply not acceptible because of this flickering.

    Just remember to not overwrite the NWjs installation, but remove the current one first (simply delete files) and install v0.13.2. Otherwise you'll have problems with huge Mac version export size.

  • I'm also having the same issue, had to take a bit of time off of C2, so i just noticed it, very annoying. Will try rolling back to v.13.1.2 as version 0.18.1 still has the same issue. thanks for the heads up

  • Rolling back worked for me.

  • Did someone who currently has to deal with these issues, test out if it's still occurring in the recent versions of C2 (r239) and NWjs (v0.18.1)?

  • Did someone who currently has to deal with these issues, test out if it's still occurring in the recent versions of C2 (r239) and NWjs (v0.18.1)?

    It works fine with NWjs 0.18.1. I have no flickering any more.

    0.13.x - no flickering

    0.14.x to 0.17.x - gives flickering

    0.18.x - no flickering

    I tested it only for around 10 minutes, but usually it started flickering within a minute, so I'm pretty sure it's fixed.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)