0 Favourites

r190 Performance Issues (Edit: Global Layers?)

  • I've just starting working on C2 this weekend after updating to r190, and it seems that all the slowdown issues I was experiencing last year have made a return. Massive slowdown when editing event sheets, and especially in the expression editor. This was something a few people with a Steam version were reporting, but it was all sorted and has been running great for a number of months now. Suddenly it's all back

    It doesn't seem like the sort of thing I can post as a bug, so just wondered if anyone else has noticed this?

  • I have the non-Steam version and have just tried reinstalling my os (w8.1) 3 times to get this to work. With no luck. I don't know if it's the same problem as yours... After about 10-15 minutes of use the editor becomes slow and clunky and eventually it half disappears/blanks and becomes unresponsive. This is not a reset dialogs problem, I don't think, as it will happen straight away with a new install of c2. I am currently trying to identify a software confliction that might cause this as reinstalling the os makes zero difference; if that fails then I will have to try a roll back to 3 months ago to see if that helps..... All drivers etc are cutting edge...

  • Also on 8.1 here, and I've updated all my drivers. I've found that restarting Construct & Steam fixes the problem temporarily, but then I get the slowdown again after about 20 minutes.

  • I even tried disabling Windows updates, with the aim of running my laptop in isolation, but that didn't work. I'm currently uninstalling everything non-Windows in case the cause lies there. My first warning of impending failure happens when I change tabs or otherwise interact with the editor and the tab bar goes black for up to a second before reappearing (or this happens to another part of the editor window, but always the small bits). If I don't close and restart at that first warning then I risk a freeze up shortly thereafter - I've become very good at pressing the save button! So far I have created 800+ events and the project size is 5 Mb, lots of small graphics items and nothing too large (18 mb memory according to the editor). I speculate that this has something to do with the undo action log, but that's really just a guess as the failures seem connected to work volume. This doesn't seem to happen when playing around with a simple project.

  • Interesting, my projects aren't small either (500 events, 25mb memory). I'll post back if I figure anything out. Just for reference, the previous thread is HERE

  • Colludium

    Strange...my current project is up to ~850 events, but I haven't had any stability issues. In fact, I don't think I can ever remember C2 crashing or hanging on me (unlike CC). Did this just start with r190?

    The only difference I can think of is I'm on Win 7. Also, I tend to stop/start a lot, so I'll make a handful of changes, test, save, close the editor, and bring it back up. I don't tend to use 'undo' a lot either, unless I have to.

    @SecondDimension

    I don't have steam, so I can't give specific feedback there. It does seem like, out of the few people who've had issues with the C2 editor, many have been using the steam edition. I think some of the blame comes down on steam itself; their services are great, but I've never been fond of their software.

  • Thanks TiAm, I fear that it's just a random hardware driver incompatibility issue with my specific system (it's a high end gaming laptop). I'm just about to test on my wife's machine to see if that has the same problem. I expect that it's not a c2 problem and I'm going to have to go computer shopping...

  • Colludium

    I feel ya I've had the same kind of baffling issues with other programs...it's incredibly frustrating, especially when you hit a brick wall and there's no one else having the same problem. Seems to occur with laptops more than desktops.

    OT, do you run an SSD in your laptop? I switched my OS over from HDD about a year ago, the difference was/still is mind-boggling. Back during the HDD days C2 could be mighty slow sometimes...

  • TiAm, I have experienced the delight of SSD and will never be able to go back, ever... My current laptop (the one I am going to have to ebay soon... ) has the os on mSATA drives in a raid config - from power off to owning the desktop in about 8 secs... It's how computers always should have been!

    I just installed a slightly older version of Java to see if that was the culprit - nope! Sigh.... It's probably something like the keyboard driver - you know, something I cannot uninstall.

    Edit - Pah! It looks like it's going to be a 3rd party plugin. Now to unpick my project and find out which one is the culprit. So - good news is I don't need to waste money on a new computer; bad news - by filling the gaps in the c2 plugin list I have put my project in jeopardy. Sulk...

  • Colludium

    Well, that's sort of good news (though, it sort of isn't ). I've been wary of third party plugins for that very reason, though some are mighty tempting.

    If you figure out what plugin is causing the problem, please let us know...

  • How is a plugin bogging down your system? some kind of memory leak?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • QuaziGNRLnose, I don't know... I was hoping it would be a driver incompatibility but the same thing happened when I tested the project on a different computer with a totally different hardware spec and version of windows.

    The editor predominantly crashes when I preview the game... If the game previews and I see all of the text objects in the HUD display are in a tiny font then I know the editor has crashed during compilation. My browser icon and the task manager icon in the task bar then all change to the C2 icon as well (until mouse over)... The editor then is unresponsive (mostly) but it will go in and out of focus; I cannot take a screen shot of what it looks like for some reason - half of the editor goes blank or it colours black. I have so far removed all webgl effects with no effects to be shown in the editor, to no change in stability. I am now writing my own replacement for the hand full of third party plugins I use.

    I did wander about a memory leak but C2 seems to max out at using about 400 Mb and that doesn't seem to constantly increase as I would imagine a leak would cause.

    It's going to take me a day or two to write my behaviours in events. I'll post the results of what I learn here (it was happening before r190); there is no way this can make a bug report, unless I say 'just do work in the editor, on layouts and in event sheets, while saving and previewing a lot, for 15-45 mins'...

    Edit to add that I'm not sure when this started to first happen, and I am reluctant to speculate about the cause, but it was around the time that global layers were introduced (I use quite a few, so my roll back options are limited).

  • Strangely enough I had just started to use global layers when I started having the issues, so I will try taking them out and see if that helps

  • OK, so it started going slow, I turned off my global layers and it was instantly OK again. Not a fully scientific test, but perhaps that's the issue here?

    EDIT: In fact just having the layout open with the 'master' global layers seems to help. Colludium is this something you can try, or is your project too large? It sounds like we might have 2 very different issues, but thought it was worth mentioning

  • OK, been testing this all day and I can now fix the slowdown every time.

    It falls into this exact pattern:

    • Editor is fine and works as normal
    • After 15-20 minutes editor will slow down
    • Open each layout containing global master layer
    • Slowdown problems instantly go away

    Note on point 3: If the layout is already open then just clicking on the tab will have the same effect and fix the problem.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
331 35,571
Lordshiva1948's avatar
Lordshiva1948
Unread hot topic
300 118,423
blackhornet's avatar
blackhornet
Unread hot topic
187 45,138
Yann's avatar
Yann