0 Favourites

Problem with Save/Load actions

  • Hi,

    I tried to implement a more complete Save/Load system into my game, using the system actions "Save" and "Load". I was previously using Webstorage with good result, but as I am developping a much more complete desktop version, I would like to change the way the game saves.

    Up to now, I have very mitigated success with the Save/Load system actions. the game loads at the right place, but when I launch a level afterward, enemies are not attacking... for the complete game!

    This is a bug I never have when playing the game normally, so I wonder how this could happen and how I can resolve it.

    I checked this tutorial, which states that the only things that are not saved are :

    • Input state (i.e. mouse position, or whether the player was holding keys or touches)
    • AJAX requests
    • WebSocket connections
    • The XML object
    • User Media video or audio feeds
    • Facebook login
    • WebStorage state
    • CocoonJS/Windows 8 state
    • Any in-app purchases on any platform
    • Anything with the 'No Save' behavior

    But I don't think my problem could be related to any of these. I tried to save my game at different times, on 3 different layouts and it wasn't better. I thought it could be due to Save not getting the groups in the right state (activated/deactivated) so I copied my "group management" group (putting each group correct at the beginning of a layout) before loading the game, but it didn't change anything (thus I suppose each group state is loaded).

    I save and load on the same computer and same game version (I just play 2 minutes, then try to load)

    Could it be due to the fact that I was previewing the game inside Construct 2?

    Any idea of what I may do wrong?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)