0 Favourites

"Preview Effects" doesnt affect blendmodes?

  • Hi,

    i ran into a construct crashing problem the last days, i use some layers with different blendmodes and it does significally lag construct2 and it seems "Preview Effects" Option doesnt affect the blend modes. I can still work with construct2 if these layers are made invisible (but i surely cant realy work on this layers while the blend mode is active) but sometimes (or better most times) i make them visible again or save and then reopen with these layers visible, construct2 will either extremly lag or just crash.

    I have newest graphic drivers available and it does occure on two totally different machines (Thinkpad and Desktop PC), the CPU usage doesnt go up a lot while construct2 is lagging.

    Can anyone give me a hint how to prevent this behaviour? (in best case without setting all the layers to normal blend mode while working in the editor and only setting the blend modes when previewing

    (i tracked the problem down to tilemap/blendmode issue, it occures only when i use a tilemap with 1*1 tiles[construct editor seems to not realy like that, even if the tilemap itself is only 2*2 and there are no blend modes it lags/glitches] and setting three or more layers with different blend modes, but im not realy after solving this, my concern is that i just missed the right option to disable blend mode in editor, the exported or previewed game doesnt have any lags or glitches)

  • If Construct 2 crashes please fill out a bug report in the Bugs forum following all the guidelines.

    We can change 'Preview effects' to turn off blend modes as well, do you think it ought to do that?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • i thought i should investigate that more before filing a bug report, the crashing seems to happen only in this constellation so that i think there are at least two issues (tilemap with very small tiles AND the blend modes being active) playing together to crash the editor.

    In fact i think the tilemap has to do a lot with it, with only one layer and the 1*1 tilemap without blend modes the editor also behaves weird (like its a bit tired ^^) without increasing cpu usage it lags at one moment and dont respond and in the other moment its totally normal, zooming in and out seems to trigger that behaviour, but like i said, i have to investigate that more to give usefull information to track this down.

    But yes, i think a option to disable blend modes in the editor would help me a lot right now

  • What on earth do you need a 1x1 tilemap for?

  • for destroying it pixel by pixel and the blend modes to let it look like in worms, i would be happy to hear if theres a better way to achieve that

  • Ashley

    @fldr is likely referring to this example, or at least using the same technique.

  • yes exactly this

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
77 6,464
Kyatric's avatar
Kyatric Construct Team Support
Unread hot topic
27 2,796
h1k3's avatar
h1k3
Topic
18 1,342
wossi's avatar
wossi