0 Favourites

Performance issues / stutter in Chrome - Out of nowhere?

  • Last night, the game I'm working on started having a lot of frame rate stutter on my Windows 8 desktop PC. I'm pretty positive that the issue has something to do with Chrome, and not the game itself or Construct 2. Older backups of the game are having the same issue, and the game is working fine on a much slower PC that I had lying around. Furthermore, the game runs completely fine when I preview in Node-Webkit.

    Prior to when this issue started occurring, I set the game (running in preview mode in Chrome) to fullscreen mode while simultaneously changing the window size from 1280x1024 to 1920x1080, and then set it back to windowed mode. I repeated this several times. At one point, I got a black screen and a popup stating that WebGL had failed. And that's about when the problem started occurring. There was also a Construct 2 crash at some point around that time.

    I've also noticed that the text (in text objects) looks a bit different than it used to, which indicates to me that there's something going on with the way things are being rendered..

    I should note that the game isn't graphically intensive, but it is fairly CPU intensive due to a lot of AI routines firing frequently. Normally, the game hovers around 60 fps, but I'm seeing a lot of lag now. Interestingly, I've also been working on a game that's very graphically intensive but not CPU intensive-- and that game is working without a hitch in Chrome!

    So far, I've attempted the following: reinstalling Chrome and Construct 2, enabling ‘Override Software Rendering List’ under chrome://flags, deleting my browser cache, and doing a system restore to a couple of days ago. Nothing I do seems to be getting Chrome back to working the way it did before. It's not a HUGE deal since the Node-Webkit preview is working fine, but still.. totally baffled.

    Any suggestions? What could have caused webgl/html5 to randomly start having performance issues in Chrome?

  • Has chrome been updated recently ?

  • I am on a Windows 8.1 desktop PC and have had the same issue since r168 - when going fullscreen and back again, WebGL crashes every time on Chrome. That is then followed by terrible performance until I have restarted both chrome and my PC. I have got around this by just removing the fullscreen option from my game for now

  • It would be useful if Google would allow users to choose which version they have installed. As far as i know you cant download older versions anymore.

    Once again C2 users have to wait until a third party ( Google in this case ) fix the problems.

  • I'm pretty positive that the issue has something to do with Chrome, and not the game itself or Construct 2.

    So you've tried IE and Firefox and they are not affected?

  • I'm on Win7 with the latest Chrome and i see no problems with performance in all of my games.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • > I'm pretty positive that the issue has something to do with Chrome, and not the game itself or Construct 2.

    >

    So you've tried IE and Firefox and they are not affected?

    This particular game has always had performance issues on Firefox and IE that weren't present in Chrome, so I haven't used those browsers on a regular basis and it isn't easy to make a comparison. However, IE does seem to be outperforming Chrome now, which was never true in the past.

    Again, the game is very CPU-heavy.. has a very large map (10240x10240 to be exact), usually close to 1000 objects though I'm trying to get this number down (it's procedurally generated), and a lot of AI going on, though I've done my best to make this all happen as efficiently as possible. Chrome (when it's working) is soundly trouncing the other browsers.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)