0 Favourites

Performance issue when using "Wrap"

  • Greetings,

    I've been trying to troubleshoot a performance issue I'm having in one of my games and after having removed any other options I could think of, it occurred to me that perhaps C2 reloads your level a few hundred pixels before a wrap around.

    I have objects that, after dying, respawn behind the user character and out of sight until they wrap the layout. There are no new objects being loaded and the death to respawn is 1 to 1, however, their locations use some randomization such that it doesn't look like you are just playing the same layout all over again.

    Any insights into this issue? Thanks!

    For clarity, my performance issue only occurs right at the end of the layout and I have removed all objects from this area. My frame rate goes from 60 to 30 until I have wrapped and then returns to 60.

  • Do you mean the wrap behavior? It is one of the simplest behaviors requiring almost no processing, so I doubt it's that. Construct 2 also does not load anything during the running of a layout, it loads everything it needs on startup, so it can't be anything to do with that either.

    Have you read Performance Tips?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Thanks for the response, Ashley. Yes, I have read the performance tips and I don't find anything that should be causing the problem.

    I have never experienced any performance issues with any of the games or tests I have done in the past. I'm running on an Alienware beast of a machine and everything is up to date. There is clearly something I have done that has caused this problem as it only exists at the very end of the layout even though I have removed all content from this section. I do have a few particle effects through out the layout but these have never caused a problem in the past. Just to be certain, I removed them as well but no change.

    I'll keep messing with it. It will probably be something silly.

    Oh and yes, I am talking about the wrap behavior.

  • SeaHunt

    Here is a build with a lot of content removed and I am curious if anyone else experiences this lag. It seems to happen to me right after the wrap as if it is reloading the layout. I understand that it is not but I am curious if this is just a problem I am having on this machine.

    Thanks!

    P.S. To play the game use the up and down arrows to swim up and down and use the space bar to bite/eat. Avoid the big fish and avoid the hydrothermal vents.

  • Tested in FF 14 on a Intel Core i5-2500K 3.30 GHz (x4), 8 Go DDR3, NVIDIA GeForce GTX 560 Ti (driver 301.42), Win 7 Pro SP1, no fps drops, no issue at all.

    Nice art by the way, it's already very moody.

  • Excellent! Thank you for checking it out and the kind words. :) C2 makes it so easy it's almost ridiculous.

  • BTW, the motion on the jellyfish is done entirely with the sine behaviour. Amazing how organic the motion is with that feature.

  • srealist - also runs perfectly here, no FPS drop anywhere.

    Performance is complicated. It's relatively likely there is no performance issue with your project, and something else in your computer is making Chrome miss VSync intervals or some such.

  • I only noticed a performance drop when the particles effect was being used.

    IE9 60FPS with no particle effect on screen

    IE9 15FPS with particle effect on screen

    Chrome 60FPS with no particle effect on screen

    Chrome 45FPS with particle effect on screen

    After the particle effect scrolls off the screen the FPS returned to 60FPS.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)